summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/undercover/undercover-0.8.1.ebuild')
-rw-r--r--app-emacs/undercover/undercover-0.8.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-emacs/undercover/undercover-0.8.1.ebuild b/app-emacs/undercover/undercover-0.8.1.ebuild
new file mode 100644
index 000000000000..6b9177a552fb
--- /dev/null
+++ b/app-emacs/undercover/undercover-0.8.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Test coverage library for Emacs"
+HOMEPAGE="https://github.com/undercover-el/undercover.el/"
+SRC_URI="https://github.com/undercover-el/${PN}.el/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}.el-${PV}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~x86"
+RESTRICT="test" # Tests fail
+
+RDEPEND="
+ app-emacs/dash
+ app-emacs/shut-up
+"
+BDEPEND="${RDEPEND}"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"