summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/vertico/vertico-0.23.ebuild')
-rw-r--r--app-emacs/vertico/vertico-0.23.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-emacs/vertico/vertico-0.23.ebuild b/app-emacs/vertico/vertico-0.23.ebuild
new file mode 100644
index 000000000000..d2415e174e28
--- /dev/null
+++ b/app-emacs/vertico/vertico-0.23.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+NEED_EMACS=27
+
+inherit elisp
+
+DESCRIPTION="Vertical interactive completion"
+HOMEPAGE="https://github.com/minad/vertico"
+SRC_URI="https://github.com/minad/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ default
+ mv extensions/*.el . || die
+}
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}