summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/vm/vm-8.1.2.ebuild')
-rw-r--r--app-emacs/vm/vm-8.1.2.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/app-emacs/vm/vm-8.1.2.ebuild b/app-emacs/vm/vm-8.1.2.ebuild
deleted file mode 100644
index 3cc65011f9ca..000000000000
--- a/app-emacs/vm/vm-8.1.2.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit elisp eutils
-
-MY_PV="${PV/_/-}"
-MY_P="${PN}-${MY_PV}"
-DESCRIPTION="The VM mail reader for Emacs"
-HOMEPAGE="http://www.nongnu.org/viewmail/"
-SRC_URI="https://launchpad.net/vm/${PV%.*}.x/${MY_PV}/+download/${MY_P}.tgz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="bbdb ssl"
-
-DEPEND="bbdb? ( app-emacs/bbdb )"
-RDEPEND="!app-emacs/u-vm-color
- ${DEPEND}
- ssl? ( net-misc/stunnel )"
-
-S="${WORKDIR}/${MY_P}"
-SITEFILE="50${PN}-gentoo-8.0.el"
-
-src_prepare() {
- if ! use bbdb; then
- elog "Excluding vm-pcrisis.el since the \"bbdb\" USE flag is not set."
- epatch "${FILESDIR}/${PN}-8.0-no-pcrisis.patch"
- fi
- epatch "${FILESDIR}/${P}-texinfo-5.patch"
-}
-
-src_configure() {
- econf \
- --with-emacs="emacs" \
- --with-pixmapdir="${SITEETC}/${PN}" \
- $(use bbdb && echo "--with-other-dirs=${SITELISP}/bbdb")
-}
-
-src_compile() {
- emake -j1
-}
-
-src_install() {
- emake -j1 DESTDIR="${D}" install
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- dodoc CHANGES NEWS README TODO example.vm
-}