summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/yaml')
-rw-r--r--app-emacs/yaml/Manifest1
-rw-r--r--app-emacs/yaml/metadata.xml19
-rw-r--r--app-emacs/yaml/yaml-0.5.5.ebuild23
3 files changed, 43 insertions, 0 deletions
diff --git a/app-emacs/yaml/Manifest b/app-emacs/yaml/Manifest
new file mode 100644
index 000000000000..1fbebfb44dc3
--- /dev/null
+++ b/app-emacs/yaml/Manifest
@@ -0,0 +1 @@
+DIST yaml-0.5.5.tar.gz 44636 BLAKE2B d98c7b6cd94f80cd0f2fc1a1bea6c45615319c1a49f4712d48a00c6439660bc209ac1a597694478d4978ebf5e0bc60e3a6363ee5c0bccabb1b5bf1b2bdc8fc58 SHA512 9ab5eacc26fe44c49f52a4ab05c11e35c605b456b2f54420924388df52855b61adc1586ec7915363811a499c4c749355954e0de2c795bb2a4f51ebcb693758eb
diff --git a/app-emacs/yaml/metadata.xml b/app-emacs/yaml/metadata.xml
new file mode 100644
index 000000000000..19fe02ffce29
--- /dev/null
+++ b/app-emacs/yaml/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ yaml.el is a YAML parser written in Emacs List without any external
+ dependencies. It provides an interface similar to the Emacs JSON parsing
+ utility.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/zkry/yaml.el/issues/</bugs-to>
+ <remote-id type="github">zkry/yaml.el</remote-id>
+ </upstream>
+ <stabilize-allarches />
+</pkgmetadata>
diff --git a/app-emacs/yaml/yaml-0.5.5.ebuild b/app-emacs/yaml/yaml-0.5.5.ebuild
new file mode 100644
index 000000000000..e8780603abc7
--- /dev/null
+++ b/app-emacs/yaml/yaml-0.5.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="YAML parser in Emacs Lisp"
+HOMEPAGE="https://github.com/zkry/yaml.el/"
+SRC_URI="https://github.com/zkry/yaml.el/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/yaml.el-${PV}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ # "test/string-inflection-test.el" calls "(ert-run-tests-batch t)"
+ ${EMACS} ${EMACSFLAGS} -L . -l yaml-tests.el || die
+}