summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/yasnippet-snippets/yasnippet-snippets-1.0.ebuild')
-rw-r--r--app-emacs/yasnippet-snippets/yasnippet-snippets-1.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-emacs/yasnippet-snippets/yasnippet-snippets-1.0.ebuild b/app-emacs/yasnippet-snippets/yasnippet-snippets-1.0.ebuild
new file mode 100644
index 000000000000..3b0d29b244e7
--- /dev/null
+++ b/app-emacs/yasnippet-snippets/yasnippet-snippets-1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="A collection of yasnippet snippets for many languages"
+HOMEPAGE="https://github.com/AndreaCrotti/yasnippet-snippets"
+SRC_URI="https://github.com/AndreaCrotti/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-emacs/yasnippet"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() { :; }
+
+src_install() {
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ insinto "${SITEETC}/${PN}"
+ doins -r snippets/.
+ dodoc README.md
+}