summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/rust-mode/Manifest1
-rw-r--r--app-emacs/rust-mode/rust-mode-0.3.0_p20180221.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-emacs/rust-mode/Manifest b/app-emacs/rust-mode/Manifest
index 693efa22deb0..425464d3b572 100644
--- a/app-emacs/rust-mode/Manifest
+++ b/app-emacs/rust-mode/Manifest
@@ -1 +1,2 @@
+DIST rust-mode-0.3.0_p20180221.tar.xz 37392 BLAKE2B 185511a2096400254e141f213f2e9a84861c2aaf5f2259cab724aa929e07b2691ae6f36c5568de5d978809588271486377a194a77a066413df6ee995e9bbe54a SHA512 004bd1536ab2e1e708193509a307ed47e22bf1f3dc5d84816958588e312c8bf6e75ee178cc99439ec0bd427ba02030c133bb21f96c5116b175d1d7cde89e9e6c
DIST rust-mode-1_beta20150411.tar.gz 18155 BLAKE2B 140cad8709f742216822b3933cac64dc7d136fe9fbf0ddec523b395cb148cd8935587a590be41187c4cdfce43b64a72ede9a67a2e77fa7b11b9562e20ae729da SHA512 fc9fe74ba4924cf54664f37c5a88d86b38e17e4ad5e0d4d924afd7f3c8428764dece81cfbe40397460685859f34c3eb841b2c83aef8f34526f4ed3f065cc504e
diff --git a/app-emacs/rust-mode/rust-mode-0.3.0_p20180221.ebuild b/app-emacs/rust-mode/rust-mode-0.3.0_p20180221.ebuild
new file mode 100644
index 000000000000..a061b8c60336
--- /dev/null
+++ b/app-emacs/rust-mode/rust-mode-0.3.0_p20180221.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="A major emacs mode for editing Rust source code"
+HOMEPAGE="https://github.com/rust-lang/rust-mode"
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="|| ( MIT Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} ${BYTECOMPFLAGS} \
+ -l rust-mode.el -l rust-mode-tests.el \
+ -f ert-run-tests-batch-and-exit || die "tests failed"
+}
+
+src_install() {
+ elisp-install ${PN} rust-mode.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}