summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/request/Manifest1
-rw-r--r--app-emacs/request/files/50request-gentoo.el1
-rw-r--r--app-emacs/request/metadata.xml13
-rw-r--r--app-emacs/request/request-0.3.2.ebuild24
4 files changed, 39 insertions, 0 deletions
diff --git a/app-emacs/request/Manifest b/app-emacs/request/Manifest
new file mode 100644
index 000000000000..e8456622f911
--- /dev/null
+++ b/app-emacs/request/Manifest
@@ -0,0 +1 @@
+DIST request-0.3.2.tar.gz 47511 BLAKE2B df01bfd32d1580e416b8f934ee2e9803c052630d366b46134364646e6bf0bba4d0ce18b3a33c675833c6b5c07d28fcc0a03763aa8217e116a03319dd071cc0b6 SHA512 41420a2ede5a8dbc1acb2e04536d7b27b5c973ed4bebc280070b042e28ae6d15e808dad3ba84122a7f680f624bafbe72a027c374413bfd43996a3fb8720fa6b3
diff --git a/app-emacs/request/files/50request-gentoo.el b/app-emacs/request/files/50request-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/request/files/50request-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/request/metadata.xml b/app-emacs/request/metadata.xml
new file mode 100644
index 000000000000..4397e5c9d019
--- /dev/null
+++ b/app-emacs/request/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/tkf/emacs-request/issues/</bugs-to>
+ <remote-id type="github">tkf/emacs-request</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/request/request-0.3.2.ebuild b/app-emacs/request/request-0.3.2.ebuild
new file mode 100644
index 000000000000..abf719fc30a0
--- /dev/null
+++ b/app-emacs/request/request-0.3.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.4
+
+inherit elisp
+
+DESCRIPTION="Compatible layer for URL request"
+HOMEPAGE="https://github.com/tkf/emacs-request/"
+SRC_URI="https://github.com/tkf/emacs-${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/emacs-${P}
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+RESTRICT="test"
+
+RDEPEND="app-emacs/deferred"
+BDEPEND="${RDEPEND}"
+
+DOCS=( README.rst )
+SITEFILE="50${PN}-gentoo.el"