summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/haskell-mode/Manifest1
-rw-r--r--app-emacs/haskell-mode/haskell-mode-17.3.ebuild60
2 files changed, 0 insertions, 61 deletions
diff --git a/app-emacs/haskell-mode/Manifest b/app-emacs/haskell-mode/Manifest
index 9e5a090cb2e4..37c3d8cc42ab 100644
--- a/app-emacs/haskell-mode/Manifest
+++ b/app-emacs/haskell-mode/Manifest
@@ -1,2 +1 @@
-DIST haskell-mode-17.3.tar.gz 1149597 BLAKE2B 6cb39102f031d6b6e387a7f7f2419105a8b3d9f10ab5974aa1e56ca587367290253cd9ee823c9ed87fdd0490c02bfdad2c279acc84ebed2adb7a14ca3905a521 SHA512 94d11652a6dab958de94cb5e1525e3888a7463a7328110cfb39b983874f71655c30e3a05eb20f0456b71e2678a7e09f1a389fdee78d493cf08fed2a10fbcc34e
DIST haskell-mode-17.4.tar.gz 1149313 BLAKE2B b30e2051448ba749b0d0b1872f824e8624c4f7d15447a94e61a69898c097ed51f289c3d0f581acffe244178e6b406466ff622e50a395be500a807ef787f92f09 SHA512 95296f9937019a9735388fde918a609aafedaeeede55f85729ddbc0b26d91dd9d39841c6aa727cdf0ebc69161b1367ce5ca895bf9a23c0b4fde8dfa49ef66b04
diff --git a/app-emacs/haskell-mode/haskell-mode-17.3.ebuild b/app-emacs/haskell-mode/haskell-mode-17.3.ebuild
deleted file mode 100644
index b1e45dbb2392..000000000000
--- a/app-emacs/haskell-mode/haskell-mode-17.3.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit elisp
-
-DESCRIPTION="Mode for editing (and running) Haskell programs in Emacs"
-HOMEPAGE="https://haskell.github.io/haskell-mode/
- https://www.haskell.org/haskellwiki/Emacs#Haskell-mode"
-
-if [[ ${PV} == *9999* ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/haskell/${PN}.git"
-else
- SRC_URI="https://github.com/haskell/${PN}/archive/v${PV}.tar.gz
- -> ${P}.tar.gz"
- KEYWORDS="amd64 ppc ~sparc x86"
-fi
-
-LICENSE="GPL-3+ FDL-1.2+"
-SLOT="0"
-
-BDEPEND="sys-apps/texinfo"
-
-ELISP_REMOVE="
- tests/haskell-cabal-tests.el
- tests/haskell-customize-tests.el
- tests/haskell-lexeme-tests.el
-"
-
-DOCS=( NEWS README.md )
-ELISP_TEXINFO="doc/${PN}.texi"
-SITEFILE="50${PN}-gentoo.el"
-
-src_prepare() {
- # We install the logo in SITEETC, not in SITELISP
- # https://github.com/haskell/haskell-mode/issues/102
- sed -i -e "/defconst haskell-process-logo/{n;" \
- -e "s:(.*\"\\(.*\\)\".*):\"${SITEETC}/${PN}/\\1\":}" \
- haskell-process.el || die
-
- elisp_src_prepare
-}
-
-src_compile() {
- elisp_src_compile
- elisp-make-autoload-file haskell-site-file.el
-}
-
-src_test() {
- emake check-ert
-}
-
-src_install() {
- elisp_src_install
-
- insinto "${SITEETC}"/${PN}
- doins logo.svg
-}