summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/pymacs/Manifest1
-rw-r--r--app-emacs/pymacs/metadata.xml2
-rw-r--r--app-emacs/pymacs/pymacs-0.26.ebuild55
3 files changed, 57 insertions, 1 deletions
diff --git a/app-emacs/pymacs/Manifest b/app-emacs/pymacs/Manifest
index 8609dde22a4b..4be5e29baeee 100644
--- a/app-emacs/pymacs/Manifest
+++ b/app-emacs/pymacs/Manifest
@@ -1 +1,2 @@
DIST pymacs-0.25.tar.gz 120597 BLAKE2B 837c67d862c11d2a9d74cb55a055f60627834a50717d5386ec604db70a62270aa2ad3e56942602dc10a5f997ab3ce6d7f91e29a8c5b959144286182ad861b3bb SHA512 e17f7ee754413e21403d23894ee263fb0edae180a60c746b02cf101b2f0c782116e7bb61215bd0a8c689a991e211d780d220d4672b58f43108e7218a6f0c8dc0
+DIST pymacs-0.26.tar.gz 123373 BLAKE2B 0c467435d18ebcbe7b263e90096363e201dd84ba770fa702beefac4318a713954c316f335ee005ea88370be29c3710a7df04fb05b6efd3816beedbb88e38126d SHA512 ae245de130f435d947788c5ac11d8ce6534df80f70a4e35fff903f22d2b79b0f66925059ebaf53bde45cd6660ac0a8a224490f4f9e256a84e3a08f6468c14dd2
diff --git a/app-emacs/pymacs/metadata.xml b/app-emacs/pymacs/metadata.xml
index f928f5ea6cdb..a5988115fbe7 100644
--- a/app-emacs/pymacs/metadata.xml
+++ b/app-emacs/pymacs/metadata.xml
@@ -10,6 +10,6 @@
<name>Python</name>
</maintainer>
<upstream>
- <remote-id type="github">pinard/Pymacs</remote-id>
+ <remote-id type="github">dgentry/Pymacs</remote-id>
</upstream>
</pkgmetadata>
diff --git a/app-emacs/pymacs/pymacs-0.26.ebuild b/app-emacs/pymacs/pymacs-0.26.ebuild
new file mode 100644
index 000000000000..77c813340aeb
--- /dev/null
+++ b/app-emacs/pymacs/pymacs-0.26.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit elisp distutils-r1
+
+DESCRIPTION="A tool that allows both-side communication beetween Python and Emacs Lisp"
+HOMEPAGE="https://www.emacswiki.org/emacs/PyMacs"
+SRC_URI="https://github.com/dgentry/${PN^}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+#IUSE="doc"
+
+#BDEPEND="doc? (
+# >=dev-python/docutils-0.7
+# virtual/latex-base
+# )"
+
+S="${WORKDIR}/${P^}"
+DISTUTILS_IN_SOURCE_BUILD=1
+SITEFILE="50${PN}-gentoo.el"
+
+python_prepare_all() {
+ sed \
+ -e '/pymacs-python-command/s/@PYTHON@/python/' \
+ -i pymacs.el.in || die
+ distutils-r1_python_prepare_all
+}
+
+# called by distutils-r1 for every python implementation
+python_configure() {
+ # pre-process the files but don't run distutils
+ emake PYSETUP=: PYTHON=${EPYTHON}
+}
+
+# called once
+python_compile_all() {
+ elisp_src_compile
+ # "pdflatex pymacs.tex" fails with "undefined control sequence"
+ #if use doc; then
+ # VARTEXFONTS="${T}"/fonts emake RST2LATEX=rst2latex.py pymacs.pdf
+ #fi
+}
+
+python_install_all() {
+ elisp_src_install
+
+ distutils-r1_python_install_all
+ dodoc pymacs.rst
+ #use doc && dodoc pymacs.pdf
+}