summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/csharp-mode/Manifest1
-rw-r--r--app-emacs/csharp-mode/csharp-mode-1.1.1.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/app-emacs/csharp-mode/Manifest b/app-emacs/csharp-mode/Manifest
index 90dabfdb372e..53c962cfc18f 100644
--- a/app-emacs/csharp-mode/Manifest
+++ b/app-emacs/csharp-mode/Manifest
@@ -1 +1,2 @@
DIST csharp-mode-0.9.2.tar.gz 52389 BLAKE2B 897d8bf3b9e0963647071628af874a77f7181592fe21f2094082c807cb33d26e43825f36cefcd100ad46dea67d217f99ec89e5f3e2c94a639553d7334ff39bc8 SHA512 da4e0aff63600c01d1571fea19d7892af1c3bd5366b97a1d9321853db7d52f04431f0c7c16371a0ef0f8296ccbf2baf0890ceb67e48a9159faf6fd6d10cb49ab
+DIST csharp-mode-1.1.1.tar.gz 36326 BLAKE2B b76c926eb32b0ac1e72bd3c789d6d8ccda9fb234bc7148f6fef402ad4c58bb378792d8cd2c005ca0222e17a0c71ab08bf8a18869611534aa4e1f4511fa21e310 SHA512 5cce24cf5810332b127caa750e4efa64bf80fefc8ebcf4fc11ffa7f3329ef49390818305238f069c657eec7bdab9694e9bd765cfeb999d7df283053cb265cd55
diff --git a/app-emacs/csharp-mode/csharp-mode-1.1.1.ebuild b/app-emacs/csharp-mode/csharp-mode-1.1.1.ebuild
new file mode 100644
index 000000000000..ba60d34f3e08
--- /dev/null
+++ b/app-emacs/csharp-mode/csharp-mode-1.1.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="A derived Emacs mode implementing most of the C# rules"
+HOMEPAGE="https://github.com/emacs-csharp/csharp-mode"
+SRC_URI="https://github.com/emacs-csharp/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+RESTRICT="test" # tries to install an old version of dash from the network
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp-install ${PN} csharp-mode.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc README.org
+}