summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/dynamips')
-rw-r--r--app-emulation/dynamips/Manifest3
-rw-r--r--app-emulation/dynamips/dynamips-0.2.18.ebuild40
-rw-r--r--app-emulation/dynamips/dynamips-0.2.23.ebuild (renamed from app-emulation/dynamips/dynamips-0.2.21.ebuild)22
-rw-r--r--app-emulation/dynamips/metadata.xml12
4 files changed, 19 insertions, 58 deletions
diff --git a/app-emulation/dynamips/Manifest b/app-emulation/dynamips/Manifest
index 0a80e67861e2..d3d379eb9542 100644
--- a/app-emulation/dynamips/Manifest
+++ b/app-emulation/dynamips/Manifest
@@ -1,2 +1 @@
-DIST dynamips-0.2.18.tar.gz 833554 BLAKE2B 8152b436e8fc43061c5603a44ceae8feebdd4593649d2fb6a1814ca22cfce2f671f6f98df5f03ee6eeef10cf09fc444d406edd8d3b4a6037a89cf0e8301774ac SHA512 d66e32d72ecc9ebff5232377ac9aa5b966ceb08884cc7f8dc4a8cf3f56305e7cefd677624ba66278f6603a3b275c384bd0ff3905932461b1f8056106cd272a4c
-DIST dynamips-0.2.21.tar.gz 833863 BLAKE2B a3162de26839a4c99fd1f147fe0a12e04f4b225b6539aa1599550c40c6a9e21deed950b47f7afbbc1cfbe2f61a351a4185a18f56c4b63c191eccc7122e2c0115 SHA512 c7251963897b65ed5696f47f03be727cea79fe2245850c86fa6b4d8718afa10002b1e39bccefe1c7f2ba86fe6b8f52fe8663ee34f72ca3d9f846522b9b9b4d29
+DIST dynamips-0.2.23.tar.gz 835736 BLAKE2B 5ea57ffbcd289a3982d873dace5bda8941209d7a0f2e36bc0cc4266c59e266f8277a215580487fb70a505eb133672247aa76d7e41124516eb67e40b999bcd67c SHA512 b68af39cd66f10555d860437f55e63887aefdb5a949bacacf3a308cc0c4eaaab3bb9a496c5ac32fd19d3920bada807bff2af8eb66b01d8d735419fec5d134746
diff --git a/app-emulation/dynamips/dynamips-0.2.18.ebuild b/app-emulation/dynamips/dynamips-0.2.18.ebuild
deleted file mode 100644
index 1b58ec9cfdad..000000000000
--- a/app-emulation/dynamips/dynamips-0.2.18.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="Cisco 7200/3600 Simulator"
-HOMEPAGE="https://github.com/GNS3/dynamips"
-SRC_URI="https://github.com/GNS3/dynamips/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="ipv6"
-
-RDEPEND="dev-libs/elfutils
- net-libs/libpcap"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-DOCS=( ChangeLog README.md RELEASE-NOTES )
-
-PATCHES=( "${FILESDIR}/${P}-docs.patch" )
-
-src_prepare() {
- # comment out DYNAMIPS_FLAGS to respect CFLAGS
- sed -e "s:^set ( DYNAMIPS_FLAGS:#&:" -i cmake/dependencies.cmake || die
-
- cmake-utils_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DANY_COMPILER=1
- -DENABLE_IPV6="$(usex ipv6)"
- )
- cmake-utils_src_configure
-}
diff --git a/app-emulation/dynamips/dynamips-0.2.21.ebuild b/app-emulation/dynamips/dynamips-0.2.23.ebuild
index 21b04e6456e7..1a0741cc4406 100644
--- a/app-emulation/dynamips/dynamips-0.2.21.ebuild
+++ b/app-emulation/dynamips/dynamips-0.2.23.ebuild
@@ -1,26 +1,24 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit cmake-utils
+inherit cmake
DESCRIPTION="Cisco 7200/3600 Simulator"
HOMEPAGE="https://github.com/GNS3/dynamips"
SRC_URI="https://github.com/GNS3/dynamips/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="ipv6"
-
-BDEPEND="app-arch/unzip"
-RDEPEND="dev-libs/elfutils
+RDEPEND="
+ dev-libs/elfutils
net-libs/libpcap"
DEPEND="${RDEPEND}"
-DOCS=( ChangeLog README.md RELEASE-NOTES )
+DOCS=( ChangeLog README.md README.hypervisor RELEASE-NOTES )
PATCHES=( "${FILESDIR}/${PN}-0.2.18-docs.patch" )
@@ -28,13 +26,13 @@ src_prepare() {
# comment out DYNAMIPS_FLAGS to respect CFLAGS
sed -e "s:^set ( DYNAMIPS_FLAGS:#&:" -i cmake/dependencies.cmake || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
local mycmakeargs=(
-DANY_COMPILER=1
- -DENABLE_IPV6="$(usex ipv6)"
+ -DENABLE_IPV6=yes
)
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/app-emulation/dynamips/metadata.xml b/app-emulation/dynamips/metadata.xml
index 2f5d95978a96..82c5a4ca25bc 100644
--- a/app-emulation/dynamips/metadata.xml
+++ b/app-emulation/dynamips/metadata.xml
@@ -1,9 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>pinkbyte@gentoo.org</email>
- <name>Sergey Popov</name>
+ <maintainer type="person" proxied="yes">
+ <email>mmk@levelnine.at</email>
+ <name>Michael Mair-Keimberger</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
</maintainer>
<upstream>
<remote-id type="sourceforge">gns-3</remote-id>