summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/gallium-nine-standalone/gallium-nine-standalone-9999.ebuild')
-rw-r--r--app-emulation/gallium-nine-standalone/gallium-nine-standalone-9999.ebuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/app-emulation/gallium-nine-standalone/gallium-nine-standalone-9999.ebuild b/app-emulation/gallium-nine-standalone/gallium-nine-standalone-9999.ebuild
index 852055dc803a..868d83cdbb60 100644
--- a/app-emulation/gallium-nine-standalone/gallium-nine-standalone-9999.ebuild
+++ b/app-emulation/gallium-nine-standalone/gallium-nine-standalone-9999.ebuild
@@ -27,7 +27,6 @@ SLOT="0"
RDEPEND="
media-libs/mesa[d3d9,dri3,${MULTILIB_USEDEP}]
x11-libs/libX11[${MULTILIB_USEDEP}]
- x11-libs/libXext[${MULTILIB_USEDEP}]
x11-libs/libxcb[${MULTILIB_USEDEP}]
"
@@ -35,6 +34,7 @@ DEPEND="
${RDEPEND}
virtual/pkgconfig[${MULTILIB_USEDEP}]
virtual/wine[${MULTILIB_USEDEP}]
+ >=dev-util/meson-0.50.1
"
PATCHES=(
@@ -61,14 +61,11 @@ src_prepare() {
# which doesn't play well with our multi-Wine environment.
bootstrap_nine() {
local file=tools/cross-wine$(bits)
- local g9dll=Z:${EPREFIX//\//\\}\\usr\\$(get_libdir)\\d3d9-nine.dll.so
-
- # Yes, these ridiculous backslashes are needed!
- g9dll=\\\\\\\\\\\"${g9dll//\\/\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\}\\\\\\\\\\\"
+ local g9dll=\"Z:${EPREFIX}/usr/$(get_libdir)/d3d9-nine.dll.so\"
sed \
-e "s!@PKG_CONFIG@!$(tc-getPKG_CONFIG)!" \
- -e "s!@CFLAGS@!$(_meson_env_array "${CFLAGS} -DG9DLL=${g9dll}")!" \
+ -e "s!@CFLAGS@!$(_meson_env_array "${CFLAGS} '-DG9DLL=${g9dll}'")!" \
-e "s!@LDFLAGS@!$(_meson_env_array "${LDFLAGS}")!" \
${file}.in > ${file} || die
}