summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/ganeti-instance-image/ganeti-instance-image-0.6.ebuild')
-rw-r--r--app-emulation/ganeti-instance-image/ganeti-instance-image-0.6.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/app-emulation/ganeti-instance-image/ganeti-instance-image-0.6.ebuild b/app-emulation/ganeti-instance-image/ganeti-instance-image-0.6.ebuild
deleted file mode 100644
index e621e1ec228e..000000000000
--- a/app-emulation/ganeti-instance-image/ganeti-instance-image-0.6.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit eutils
-
-if [[ ${PV} == "9999" ]]; then
- EGIT_REPO_URI="git://git.osuosl.org/${PN}.git"
- EGIT_BRANCH="master"
- inherit git-2 autotools
-else
- SRC_URI="http://ftp.osuosl.org/pub/osl/ganeti-instance-image/${P}.tar.gz"
-fi
-
-DESCRIPTION="Scripts to build out CD or image based VMs using Ganeti"
-HOMEPAGE="http://code.osuosl.org/projects/ganeti-image"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="app-arch/dump
- >=app-emulation/ganeti-2.0.3
- app-emulation/qemu
- sys-apps/util-linux
- sys-fs/multipath-tools
- sys-fs/e2fsprogs"
-
-src_prepare() {
- if [[ ${PV} == "9999" ]]; then
- eautoreconf
- fi
-}
-
-src_configure() {
- econf --with-default-dir=/etc/ganeti
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- rm -rf "${D}"/usr/share/doc/${PN}
- dodoc README.markdown NEWS ChangeLog
- insinto /etc/ganeti
- newins defaults ${PN}
-}