summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/glean/glean-1.19.0.ebuild')
-rw-r--r--app-emulation/glean/glean-1.19.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-emulation/glean/glean-1.19.0.ebuild b/app-emulation/glean/glean-1.19.0.ebuild
new file mode 100644
index 000000000000..2d07441e5a1c
--- /dev/null
+++ b/app-emulation/glean/glean-1.19.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9,10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Simple program to write static config from config-drive"
+HOMEPAGE="https://opendev.org/opendev/glean"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/pbr[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ distutils-r1_src_install
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+}