summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/libguestfs-appliance')
-rw-r--r--app-emulation/libguestfs-appliance/Manifest2
-rw-r--r--app-emulation/libguestfs-appliance/files/env.file1
-rw-r--r--app-emulation/libguestfs-appliance/libguestfs-appliance-1.26.0-r1.ebuild44
-rw-r--r--app-emulation/libguestfs-appliance/libguestfs-appliance-1.28.1-r1.ebuild45
-rw-r--r--app-emulation/libguestfs-appliance/libguestfs-appliance-1.28.1.ebuild44
-rw-r--r--app-emulation/libguestfs-appliance/metadata.xml18
6 files changed, 154 insertions, 0 deletions
diff --git a/app-emulation/libguestfs-appliance/Manifest b/app-emulation/libguestfs-appliance/Manifest
new file mode 100644
index 000000000000..47caa127259f
--- /dev/null
+++ b/app-emulation/libguestfs-appliance/Manifest
@@ -0,0 +1,2 @@
+DIST appliance-1.26.0.tar.xz 94753208 SHA256 446e8f0cfb24977843049984879d471760a1f56dd9f891f2a66c16827c7dfbcf SHA512 5d493ed6e8601dde8d5a45debfee71696b96a36d0f69d428388a6f2a2d49e12c0a66bcee210fe606fc9b2b41cb42d0d2a9f5d12425f2b234423194b2609f081f WHIRLPOOL 18cb09b44ce568e4270e574fffe7ffd935c4d64564abaae66c3d70202db9df75b013a0ed8add639ac13ea4ebd0ec9d74645a774d2e969686c8bc0d616587f625
+DIST appliance-1.28.1.tar.xz 100065044 SHA256 d6aa214ba05666ca7b8494b2f1814f2f291e569a9476e837e4b9d061ff92cfa2 SHA512 f13c556953d3542f92c2c007d3e97c3568382a1879e7a558471dbeac8962bd2809e446bbf0f4647002967112abe8f9a9a06910b74e9b7d72694cf49859a26330 WHIRLPOOL fa80fc747e4270fb3bc3b853ea9abf62fd655cab4c72eb6a084d319078a9f89baf2a8c00b34c9dcbc8fb875f1526c0a8e681a6f4917710934a9c2a8d99010e04
diff --git a/app-emulation/libguestfs-appliance/files/env.file b/app-emulation/libguestfs-appliance/files/env.file
new file mode 100644
index 000000000000..577009eebf8f
--- /dev/null
+++ b/app-emulation/libguestfs-appliance/files/env.file
@@ -0,0 +1 @@
+LIBGUESTFS_PATH=/usr/share/guestfs/appliance/
diff --git a/app-emulation/libguestfs-appliance/libguestfs-appliance-1.26.0-r1.ebuild b/app-emulation/libguestfs-appliance/libguestfs-appliance-1.26.0-r1.ebuild
new file mode 100644
index 000000000000..e2b975595f27
--- /dev/null
+++ b/app-emulation/libguestfs-appliance/libguestfs-appliance-1.26.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+CHECKREQS_DISK_USR=500M
+CHECKREQS_DISK_BUILD=500M
+
+inherit check-reqs
+
+DESCRIPTION="VM appliance disk image used in libguestfs package"
+HOMEPAGE="http://libguestfs.org/"
+SRC_URI="http://libguestfs.org/download/binaries/appliance/appliance-${PV}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/xz-utils"
+# Mixing libguestfs versions causes weird problems. #501588
+RDEPEND="!<app-emulation/libguestfs-${PV}"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ # We'll unpack the tarball directly into ${D} to speed up install.
+ # Otherwise we need to duplicate hundreds of data.
+ :
+}
+
+src_install() {
+ dodir /usr/share/guestfs
+ cd "${ED}"/usr/share/guestfs
+ unpack ${A}
+ cd appliance || die
+ dodoc README*
+ rm README* || die
+ chmod 755 . || die
+ chmod 644 * || die
+
+ newenvd "${FILESDIR}"/env.file 99"${PN}"
+}
diff --git a/app-emulation/libguestfs-appliance/libguestfs-appliance-1.28.1-r1.ebuild b/app-emulation/libguestfs-appliance/libguestfs-appliance-1.28.1-r1.ebuild
new file mode 100644
index 000000000000..9778bc868515
--- /dev/null
+++ b/app-emulation/libguestfs-appliance/libguestfs-appliance-1.28.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+CHECKREQS_DISK_USR=500M
+CHECKREQS_DISK_BUILD=500M
+
+inherit check-reqs
+
+DESCRIPTION="VM appliance disk image used in libguestfs package"
+HOMEPAGE="http://libguestfs.org/"
+SRC_URI="http://libguestfs.org/download/binaries/appliance/appliance-${PV}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/xz-utils"
+# Mixing libguestfs versions causes weird problems. #501588
+RDEPEND="!<app-emulation/libguestfs-${PV}"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ # We'll unpack the tarball directly into ${D} to speed up install.
+ # Otherwise we need to duplicate hundreds of data.
+ :
+}
+
+src_install() {
+ dodir /usr/share/guestfs
+ cd "${ED}"/usr/share/guestfs
+ unpack ${A}
+ cd appliance || die
+ dodoc README*
+ # Don't rm README.* here, at least README.fixed is needed for libguestfs, see
+ # https://bugzilla.redhat.com/show_bug.cgi?id=1183780
+ chmod 755 . || die
+ chmod 644 * || die
+
+ newenvd "${FILESDIR}"/env.file 99"${PN}"
+}
diff --git a/app-emulation/libguestfs-appliance/libguestfs-appliance-1.28.1.ebuild b/app-emulation/libguestfs-appliance/libguestfs-appliance-1.28.1.ebuild
new file mode 100644
index 000000000000..e2b975595f27
--- /dev/null
+++ b/app-emulation/libguestfs-appliance/libguestfs-appliance-1.28.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+CHECKREQS_DISK_USR=500M
+CHECKREQS_DISK_BUILD=500M
+
+inherit check-reqs
+
+DESCRIPTION="VM appliance disk image used in libguestfs package"
+HOMEPAGE="http://libguestfs.org/"
+SRC_URI="http://libguestfs.org/download/binaries/appliance/appliance-${PV}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/xz-utils"
+# Mixing libguestfs versions causes weird problems. #501588
+RDEPEND="!<app-emulation/libguestfs-${PV}"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ # We'll unpack the tarball directly into ${D} to speed up install.
+ # Otherwise we need to duplicate hundreds of data.
+ :
+}
+
+src_install() {
+ dodir /usr/share/guestfs
+ cd "${ED}"/usr/share/guestfs
+ unpack ${A}
+ cd appliance || die
+ dodoc README*
+ rm README* || die
+ chmod 755 . || die
+ chmod 644 * || die
+
+ newenvd "${FILESDIR}"/env.file 99"${PN}"
+}
diff --git a/app-emulation/libguestfs-appliance/metadata.xml b/app-emulation/libguestfs-appliance/metadata.xml
new file mode 100644
index 000000000000..4b62b2824c99
--- /dev/null
+++ b/app-emulation/libguestfs-appliance/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proxy-maintainers</herd>
+<maintainer>
+ <email>andreis.vinogradovs@gmail.com</email>
+ <name>Andreis Vinogradovs</name>
+</maintainer>
+<maintainer>
+ <email>maksbotan@gentoo.org</email>
+ <name>Maxim Koltsov</name>
+</maintainer>
+<maintainer>
+ <email>rich@annexia.org</email>
+ <name>Richard Jones</name>
+ <description>Upstream - please CC on bugs that concerns upstream</description>
+</maintainer>
+</pkgmetadata>