summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/ruffle/ruffle-9999.ebuild')
-rw-r--r--app-emulation/ruffle/ruffle-9999.ebuild25
1 files changed, 7 insertions, 18 deletions
diff --git a/app-emulation/ruffle/ruffle-9999.ebuild b/app-emulation/ruffle/ruffle-9999.ebuild
index ced4e9790b1e..fbc440002e65 100644
--- a/app-emulation/ruffle/ruffle-9999.ebuild
+++ b/app-emulation/ruffle/ruffle-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cargo desktop flag-o-matic git-r3 virtualx xdg
+inherit cargo desktop flag-o-matic git-r3 xdg
DESCRIPTION="Flash Player emulator written in Rust"
HOMEPAGE="https://ruffle.rs/"
@@ -16,6 +16,8 @@ LICENSE+="
Unicode-DFS-2016 ZLIB curl
" # crates
SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
# dlopen: libX* (see winit+x11-dl crates)
RDEPEND="
@@ -37,14 +39,14 @@ BDEPEND="
virtual/jre:*
virtual/pkgconfig
>=virtual/rust-1.70
- test? (
- media-libs/mesa[llvm]
- x11-base/xorg-server[-minimal]
- )
"
QA_FLAGS_IGNORED="usr/bin/${PN}.*"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0_p20230724-skip-render-tests.patch
+)
+
src_unpack() {
git-r3_src_unpack
@@ -79,19 +81,6 @@ src_configure() {
cargo_src_configure ${workspaces[*]/#/--package=}
}
-src_test() {
- xdg_environment_reset
-
- local skip=(
- # this should be fine on real hardware, but currently fails with mesa's
- # software rendering (bug #911320) -- note they are auto-skipped if
- # USE=-gles2 on mesa, and this just forces to skip regardless
- --skip visual/filters/displacement_map
- )
-
- virtx cargo_src_test -- "${skip[@]}"
-}
-
src_install() {
dodoc README.md