summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/runc')
-rw-r--r--app-emulation/runc/Manifest1
-rw-r--r--app-emulation/runc/metadata.xml30
-rw-r--r--app-emulation/runc/runc-1.0.0_rc10-r1.ebuild78
3 files changed, 0 insertions, 109 deletions
diff --git a/app-emulation/runc/Manifest b/app-emulation/runc/Manifest
deleted file mode 100644
index 0c5009ddfbe3..000000000000
--- a/app-emulation/runc/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST runc-1.0.0_rc10.tar.gz 1929802 BLAKE2B 8399c3d62726bbb6256efef7e15b7496a7172bf25170b12beb60be498967dec4fde2aebd073de4265e132ff864bafc4d2499ab677390a4f7c0a1605d83ae55e5 SHA512 598221071ef07d18bf34bf5d5c68b8ad78ee71716177fc3ce5b6909cd841d5aed93f17ebf1f3d134707d29eef1f54a4ddc21e79621a9bd957df28a8d2e028ab7
diff --git a/app-emulation/runc/metadata.xml b/app-emulation/runc/metadata.xml
deleted file mode 100644
index 8b7ea39239c3..000000000000
--- a/app-emulation/runc/metadata.xml
+++ /dev/null
@@ -1,30 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <longdescription lang="en">
- runc is a CLI tool for spawning and running containers according
- to the OCF (Open Container Format) specification.
- </longdescription>
- <maintainer type="person">
- <email>williamh@gentoo.org</email>
- <name>William Hubbs</name>
- </maintainer>
- <maintainer type="person">
- <email>gyakovlev@gentoo.org</email>
- <name>Georgy Yakovlev</name>
- </maintainer>
- <use>
- <flag name="ambient">
- Enable support for ambient capabilities set (Requires Linux kernel 4.3 or later).
- </flag>
- <flag name="apparmor">
- Enable AppArmor support.
- </flag>
- <flag name="kmem">
- Enable Kernel Memory Accounting.
- </flag>
- </use>
- <upstream>
- <remote-id type="github">opencontainers/runc</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/app-emulation/runc/runc-1.0.0_rc10-r1.ebuild b/app-emulation/runc/runc-1.0.0_rc10-r1.ebuild
deleted file mode 100644
index 9f60bd86db13..000000000000
--- a/app-emulation/runc/runc-1.0.0_rc10-r1.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit golang-vcs-snapshot linux-info
-
-# update on bump, look for https://github.com/docker\
-# docker-ce/blob/<docker ver OR branch>/components/engine/hack/dockerfile/install/runc.installer
-RUNC_COMMIT="dc9208a3303feef5b3839f4323d9beb36df0a9dd"
-CONFIG_CHECK="~USER_NS"
-EGO_PN="github.com/opencontainers/${PN}"
-
-DESCRIPTION="runc container cli tools"
-HOMEPAGE="http://runc.io"
-SRC_URI="https://github.com/opencontainers/${PN}/archive/v${RUNC_COMMIT}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD-2 BSD MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ppc64 ~x86"
-IUSE="apparmor +ambient hardened +kmem +seccomp selinux test"
-
-DEPEND="seccomp? ( sys-libs/libseccomp )"
-
-RDEPEND="
- ${DEPEND}
- !app-emulation/docker-runc
- apparmor? ( sys-libs/libapparmor )
-"
-
-BDEPEND="
- dev-go/go-md2man
- test? ( "${RDEPEND}" )
-"
-
-# tests need busybox binary, and portage namespace
-# sandboxing disabled: mount-sandbox pid-sandbox ipc-sandbox
-# majority of tests pass
-RESTRICT+=" test"
-
-src_compile() {
- # Taken from app-emulation/docker-1.7.0-r1
- export CGO_CFLAGS="-I${ROOT}/usr/include"
- export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')
- -L${ROOT}/usr/$(get_libdir)"
-
- # build up optional flags
- local options=(
- $(usev ambient)
- $(usev apparmor)
- $(usev seccomp)
- $(usev selinux)
- $(usex kmem '' 'nokmem')
- )
-
- myemakeargs=(
- BINDIR="${ED}/usr/bin"
- BUILDTAGS="${options[*]}"
- COMMIT=${RUNC_COMMIT}
- DESTDIR="${ED}"
- PREFIX="${ED}/usr"
- GOPATH="${S}"
- -C "src/${EGO_PN}"
- )
-
- emake "${myemakeargs[@]}" runc man
-}
-
-src_install() {
- emake "${myemakeargs[@]}" install install-man install-bash
-
- local DOCS=( src/"${EGO_PN}"/{README.md,PRINCIPLES.md,docs/.} )
- einstalldocs
-}
-
-src_test() {
- emake "${myemakeargs[@]}" localunittest
-}