summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/runc')
-rw-r--r--app-emulation/runc/runc-1.0.0_rc2.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/app-emulation/runc/runc-1.0.0_rc2.ebuild b/app-emulation/runc/runc-1.0.0_rc2.ebuild
index 0844ed4146cc..da27cda50ffe 100644
--- a/app-emulation/runc/runc-1.0.0_rc2.ebuild
+++ b/app-emulation/runc/runc-1.0.0_rc2.ebuild
@@ -20,7 +20,7 @@ HOMEPAGE="http://runc.io"
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="apparmor +seccomp"
+IUSE="apparmor hardened +seccomp"
DEPEND=""
RDEPEND="
@@ -33,7 +33,8 @@ S=${WORKDIR}/${P}/src/${EGO_PN}
src_compile() {
# Taken from app-emulation/docker-1.7.0-r1
export CGO_CFLAGS="-I${ROOT}/usr/include"
- export CGO_LDFLAGS="-L${ROOT}/usr/$(get_libdir)"
+ export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')
+ -L${ROOT}/usr/$(get_libdir)"
# Setup GOPATH so things build
rm -rf .gopath