summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/ski')
-rw-r--r--app-emulation/ski/files/ski-1.3.2-gcc-10.patch22
-rw-r--r--app-emulation/ski/ski-1.3.2-r3.ebuild3
2 files changed, 24 insertions, 1 deletions
diff --git a/app-emulation/ski/files/ski-1.3.2-gcc-10.patch b/app-emulation/ski/files/ski-1.3.2-gcc-10.patch
new file mode 100644
index 000000000000..bfe5de33acbf
--- /dev/null
+++ b/app-emulation/ski/files/ski-1.3.2-gcc-10.patch
@@ -0,0 +1,22 @@
+--- a/src/linux/syscall-linux.c
++++ b/src/linux/syscall-linux.c
+@@ -538,7 +538,7 @@ pid_t cons_pid = -1;
+ static int cfd = -1;
+ BOOL trace_syscalls;
+ char *consLog = NULL;
+-extern BOOL noConsole;
++BOOL noConsole;
+ extern BOOL userint;
+ static struct termios sane_ttyIos;
+
+--- a/src/platform.c
++++ b/src/platform.c
+@@ -29,7 +29,7 @@
+ #include "platform.h"
+ #include "state.h"
+
+-BOOL autoAlloc, noConsole;
++extern BOOL autoAlloc, noConsole;
+ extern char *consLog;
+ extern unsigned va_len, pa_len, rid_len, key_len;
+ extern unsigned mips;
diff --git a/app-emulation/ski/ski-1.3.2-r3.ebuild b/app-emulation/ski/ski-1.3.2-r3.ebuild
index 1063017aad06..e64df45c1250 100644
--- a/app-emulation/ski/ski-1.3.2-r3.ebuild
+++ b/app-emulation/ski/ski-1.3.2-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -38,6 +38,7 @@ PATCHES=(
"${FILESDIR}"/${P}-ncurses-config.patch
"${FILESDIR}"/${P}-prototypes.patch
"${FILESDIR}"/${P}-glibc-2.28.patch
+ "${FILESDIR}"/${P}-gcc-10.patch #707144
)
src_prepare() {