summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/spice-protocol/spice-protocol-9999.ebuild')
-rw-r--r--app-emulation/spice-protocol/spice-protocol-9999.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-emulation/spice-protocol/spice-protocol-9999.ebuild b/app-emulation/spice-protocol/spice-protocol-9999.ebuild
new file mode 100644
index 000000000000..2d21d4c757a4
--- /dev/null
+++ b/app-emulation/spice-protocol/spice-protocol-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-2 autotools
+ EGIT_REPO_URI="git://anongit.freedesktop.org/spice/spice-protocol"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://spice-space.org/download/releases/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+DESCRIPTION="Headers defining the SPICE protocol"
+HOMEPAGE="http://spice-space.org/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ [[ ${PV} = *9999* ]] && eautoreconf
+ default
+}