summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/vice')
-rw-r--r--app-emulation/vice/Manifest1
-rw-r--r--app-emulation/vice/files/vice-pkg-config.patch29
-rw-r--r--app-emulation/vice/vice-3.4_p37605.ebuild176
3 files changed, 0 insertions, 206 deletions
diff --git a/app-emulation/vice/Manifest b/app-emulation/vice/Manifest
index 98153090bfff..5c23e52b7bf4 100644
--- a/app-emulation/vice/Manifest
+++ b/app-emulation/vice/Manifest
@@ -1,3 +1,2 @@
DIST vice-emu-code-r37498-trunk-vice.zip 26810776 BLAKE2B 05baa0d123e9a0f1141ef68940455b5abfccde0204d0ffeb0a806212977be6f1f2c777267cad077272f4e09fa3c6adb9e95436adaaee5482b2ce918a3485caeb SHA512 5b4c31e51efc67ac08f6fe9361c42b80115b315fc24c128861341f2eea7567bdbb1761e52bc914df442ed5cc7f2ca7c6b0a2694441d63e63f9f693bcf72c70c0
-DIST vice-emu-code-r37605-trunk-vice.zip 26854864 BLAKE2B 771728b69cb38492d086d199fcb56d19f14738bc6b5c3f0b1c9c6ffb07db0d2c2a3d631ed9f32a2abf0159d4e3e0d144c04e6ba13c22ce619ea1090f89b7b5cc SHA512 975c342d5ee7f72cc775bee711fed77fb6ce00bc15eef13403b9f3a457ac589d0089bcdf452507605bbf11d8806fceec94729becf1ef3fe66f6074854684d998
DIST vice-emu-code-r38553-trunk-vice.zip 27146846 BLAKE2B 5139e4b1e9269c3885313889dffc055298c52152da77e5a824270feb0af6ba61a1726160a6d259e9f8840fefe486cc184f5bfda3ba1797e0359159ccf1e9824f SHA512 c4d3f132bae2980163e74695126e979bd68dddecb17c2eea8227edbb675985d1f04ade665b946a5e3c707bc17e260efb61f57aa141b6ef712385d4d85a68ef86
diff --git a/app-emulation/vice/files/vice-pkg-config.patch b/app-emulation/vice/files/vice-pkg-config.patch
deleted file mode 100644
index d29eff252fb5..000000000000
--- a/app-emulation/vice/files/vice-pkg-config.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-https://sourceforge.net/p/vice-emu/patches/218/
-
-Index: configure.proto
-===================================================================
---- a/configure.proto (revision 37525)
-+++ b/configure.proto (working copy)
-@@ -1275,6 +1275,14 @@
- fi
-
- if test x"$found_sdl2" != "xyes"; then
-+ PKG_CHECK_MODULES(SDL2, sdl2, [
-+ use_sdl_prefix=no
-+ use_sdl2_prefix=no
-+ found_sdl2=yes
-+ VICE_CFLAGS="$VICE_CFLAGS $SDL2_CFLAGS"
-+ VICE_CXXFLAGS="$VICE_CXXFLAGS $SDL2_CFLAGS"
-+ LIBS="$LIBS $SDL2_LIBS"
-+ ], [
- dnl Check for sdl2-config
- if test x"$sdl2_config" != "xno"; then
- user_CFLAGS="$CFLAGS"
-@@ -1311,6 +1319,7 @@
- CFLAGS="$user_CFLAGS"
- CXXFLAGS="$user_CXXFLAGS"
- fi
-+ ])
- fi
-
- dnl fail if SDL2 ui was requested, otherwise restore flags and continue
diff --git a/app-emulation/vice/vice-3.4_p37605.ebuild b/app-emulation/vice/vice-3.4_p37605.ebuild
deleted file mode 100644
index 23c94697352c..000000000000
--- a/app-emulation/vice/vice-3.4_p37605.ebuild
+++ /dev/null
@@ -1,176 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools multibuild
-
-MY_P="vice-emu-code-r${PV##*_p}-trunk-vice"
-
-DESCRIPTION="The Versatile Commodore Emulator"
-HOMEPAGE="https://vice-emu.sourceforge.io/"
-#SRC_URI="mirror://sourceforge/vice-emu/releases/${P}.tar.gz"
-SRC_URI="https://sourceforge.net/code-snapshots/svn/v/vi/vice-emu/code/${MY_P}.zip"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="alsa debug doc ethernet ffmpeg flac gif +gtk headless ipv6 jpeg lame mpg123 ogg oss +opengl parport pci png portaudio pulseaudio sdl zlib"
-REQUIRED_USE="|| ( gtk headless sdl ) gtk? ( zlib )"
-
-RDEPEND="
- sys-libs/readline:0=
- virtual/libintl
- alsa? ( media-libs/alsa-lib )
- ethernet? (
- >=net-libs/libpcap-0.9.8
- >=net-libs/libnet-1.1.2.1:1.1
- )
- ffmpeg? ( media-video/ffmpeg:= )
- flac? ( media-libs/flac )
- gif? ( media-libs/giflib:= )
- gtk? (
- dev-libs/glib:2
- media-libs/fontconfig:1.0
- x11-libs/gtk+:3
- opengl? (
- media-libs/glew:0=
- virtual/opengl
- )
- )
- jpeg? ( virtual/jpeg )
- lame? ( media-sound/lame )
- mpg123? ( media-sound/mpg123 )
- ogg? (
- media-libs/libogg
- media-libs/libvorbis
- )
- parport? ( sys-libs/libieee1284 )
- pci? ( sys-apps/pciutils )
- png? ( media-libs/libpng:0= )
- portaudio? ( media-libs/portaudio )
- pulseaudio? ( media-sound/pulseaudio )
- sdl? ( media-libs/libsdl2[video] )
- zlib? ( sys-libs/zlib )
-"
-
-DEPEND="
- ${RDEPEND}
- x11-base/xorg-proto
-"
-
-BDEPEND="
- app-arch/unzip
- dev-embedded/xa
- dev-lang/perl
- sys-apps/texinfo
- sys-devel/flex
- sys-devel/gettext
- virtual/pkgconfig
- virtual/yacc
- doc? ( virtual/texi2dvi )
-"
-
-S="${WORKDIR}/${MY_P}"
-ECONF_SOURCE="${S}"
-
-PATCHES=(
- "${FILESDIR}"/vice-pkg-config.patch
-)
-
-src_prepare() {
- default
-
- # Delete some bundled libraries.
- rm -r src/lib/lib{ffmpeg,lame,x264} || die
-
- sed "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g" < configure.proto > configure.ac || die
-
- local DIR
- for DIR in src/resid src/resid-dtv .; do
- pushd "${DIR}" || die
- AT_NO_RECURSIVE=1 eautoreconf
- popd || die
- done
-
- # Strip the predefined C(XX)FLAGS.
- sed -i -r 's:(VICE_C(XX)?FLAGS=)"[^$]+":\1:' configure || die
-}
-
-src_configure() {
- MULTIBUILD_VARIANTS=(
- $(usev gtk)
- $(usev headless)
- $(usev sdl)
- )
-
- multibuild_foreach_variant run_in_build_dir multibuild_src_configure
-}
-
-multibuild_enable() {
- if [[ ${MULTIBUILD_VARIANT} == $1 ]]; then
- printf -- "--enable-%s\n" "$2"
- else
- printf -- "--disable-%s\n" "$2"
- fi
-}
-
-multibuild_src_configure() {
- # Some dependencies lack configure options so prevent them becoming
- # automagic by using configure cache variables.
- use flac || export ac_cv_header_FLAC_stream_decoder_h=no
- use mpg123 || export ac_cv_header_mpg123_h=no
- use ogg || export ac_cv_header_vorbis_vorbisfile_h=no
- use pci || export ac_cv_header_pci_pci_h=no
-
- # Ensure we use giflib, not ungif.
- export ac_cv_lib_ungif_EGifPutLine=no
-
- # Append ".variant" to x* programs if building multiple variants.
- if [[ ${#MULTIBUILD_VARIANTS[@]} -gt 1 ]]; then
- xform="/^x/s/\$/.${MULTIBUILD_VARIANT}/"
- else
- unset xform
- fi
-
- econf \
- --program-transform-name="${xform}" \
- --disable-sdlui \
- $(multibuild_enable sdl sdlui2) \
- $(multibuild_enable gtk native-gtk3ui) \
- $(use_enable debug debug-gtk3ui) \
- $(multibuild_enable headless headlessui) \
- $(use_enable opengl hwscale) \
- --disable-shared-ffmpeg \
- --disable-static-ffmpeg \
- $(use_enable ffmpeg external-ffmpeg) \
- $(use_enable ethernet) \
- $(use_enable ipv6) \
- $(use_enable parport libieee1284) \
- $(use_enable portaudio) \
- $(use_enable lame) \
- $(use_enable debug) \
- --disable-arch \
- $(use_enable doc pdf-docs) \
- --enable-html-docs \
- $(use_with pulseaudio pulse) \
- $(use_with alsa) \
- $(use_with oss) \
- $(use_with jpeg) \
- $(use_with png) \
- $(use_with gif) \
- $(use_with zlib)
-}
-
-src_compile() {
- multibuild_foreach_variant run_in_build_dir emake
-}
-
-src_install() {
- multibuild_foreach_variant run_in_build_dir default
- dodoc FEEDBACK
-
- # Delete the bundled fonts. These could be packaged separately but
- # they're only for the HTML documentation.
- rm -r "${ED}"/usr/share/doc/${PF}/html/fonts/ || die
-}