summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/wine-proton/wine-proton-9.0.9999.ebuild')
-rw-r--r--app-emulation/wine-proton/wine-proton-9.0.9999.ebuild25
1 files changed, 18 insertions, 7 deletions
diff --git a/app-emulation/wine-proton/wine-proton-9.0.9999.ebuild b/app-emulation/wine-proton/wine-proton-9.0.9999.ebuild
index fda342d879f2..caa389a5712f 100644
--- a/app-emulation/wine-proton/wine-proton-9.0.9999.ebuild
+++ b/app-emulation/wine-proton/wine-proton-9.0.9999.ebuild
@@ -4,7 +4,7 @@
EAPI=8
MULTILIB_COMPAT=( abi_x86_{32,64} )
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit autotools flag-o-matic multilib multilib-build prefix
inherit python-any-r1 readme.gentoo-r1 toolchain-funcs wrapper
@@ -44,7 +44,7 @@ WINE_DLOPEN_DEPEND="
dev-libs/libgcrypt:=[${MULTILIB_USEDEP}]
media-libs/freetype[${MULTILIB_USEDEP}]
media-libs/libglvnd[X,${MULTILIB_USEDEP}]
- media-libs/vulkan-loader[${MULTILIB_USEDEP}]
+ media-libs/vulkan-loader[X,${MULTILIB_USEDEP}]
x11-libs/libXcursor[${MULTILIB_USEDEP}]
x11-libs/libXfixes[${MULTILIB_USEDEP}]
x11-libs/libXi[${MULTILIB_USEDEP}]
@@ -134,6 +134,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-7.0.4-noexecstack.patch
"${FILESDIR}"/${PN}-8.0.1c-unwind.patch
"${FILESDIR}"/${PN}-8.0.4-restore-menubuilder.patch
+ "${FILESDIR}"/${PN}-8.0.5c-vulkan-libm.patch
"${FILESDIR}"/${PN}-9.0-rpath.patch
)
@@ -269,6 +270,7 @@ src_configure() {
)
filter-lto # build failure
+ filter-flags -Wl,--gc-sections # runtime issues (bug #931329)
use custom-cflags || strip-flags # can break in obscure ways at runtime
# wine uses linker tricks unlikely to work with non-bfd/lld (bug #867097)
@@ -405,11 +407,20 @@ pkg_postinst() {
ewarn "work, be warned that it is not unusual that installers or other helpers"
ewarn "will attempt to use 32bit and fail. If do not want full USE=abi_x86_32,"
ewarn "note the experimental/WIP USE=wow64 can allow 32bit without multilib."
- elif use abi_x86_32 && has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'
- then
- ewarn "x11-drivers/nvidia-drivers is installed but is built without"
- ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
- ewarn "applications under ${PN} will likely not be usable."
+ elif use abi_x86_32; then
+ # difficult to tell what is needed from here, but try to warn
+ if has_version 'x11-drivers/nvidia-drivers'; then
+ if has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'; then
+ ewarn "x11-drivers/nvidia-drivers is installed but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
+ ewarn "Multi-card setups may need this on media-libs/mesa as well."
+ fi
+ elif has_version 'media-libs/mesa[-abi_x86_32]'; then
+ ewarn "media-libs/mesa seems to be in use but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
+ fi
fi
eselect wine update --if-unset || die