summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/wine-staging/wine-staging-7.5.ebuild')
-rw-r--r--app-emulation/wine-staging/wine-staging-7.5.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/app-emulation/wine-staging/wine-staging-7.5.ebuild b/app-emulation/wine-staging/wine-staging-7.5.ebuild
index cf584a42b185..1ad582f1f5d0 100644
--- a/app-emulation/wine-staging/wine-staging-7.5.ebuild
+++ b/app-emulation/wine-staging/wine-staging-7.5.ebuild
@@ -48,7 +48,7 @@ fi
LICENSE="LGPL-2.1"
SLOT="${MY_PV}"
-IUSE="+abi_x86_32 +abi_x86_64 +alsa capi cups custom-cflags dos elibc_glibc +fontconfig +gecko gphoto2 gssapi gstreamer kerberos ldap mingw +mono mp3 netapi nls odbc openal opencl +opengl osmesa oss +perl pcap pipelight pulseaudio +realtime +run-exes samba scanner sdl selinux +ssl staging test +threads +truetype udev +udisks +unwind usb v4l vkd3d vulkan +X +xcomposite xinerama"
+IUSE="+abi_x86_32 +abi_x86_64 +alsa capi cups custom-cflags dos +fontconfig +gecko gphoto2 gssapi gstreamer kerberos ldap mingw +mono mp3 netapi nls odbc openal opencl +opengl osmesa oss +perl pcap pipelight pulseaudio +realtime +run-exes samba scanner sdl selinux +ssl staging test +threads +truetype udev +udisks +unwind usb v4l vkd3d vulkan +X +xcomposite xinerama"
REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )
X? ( truetype )
elibc_glibc? ( threads )
@@ -117,6 +117,7 @@ RDEPEND="${COMMON_DEPEND}
!app-emulation/wine:0
dos? ( >=games-emulation/dosbox-0.74_p20160629 )
gecko? ( app-emulation/wine-gecko:2.47.2[abi_x86_32?,abi_x86_64?] )
+ mingw? ( !!>=cross-i686-w64-mingw32/binutils-2.38 !!>=cross-x86_64-w64-mingw32/binutils-2.38 )
mono? ( app-emulation/wine-mono:7.1.1 )
perl? (
dev-lang/perl
@@ -275,8 +276,8 @@ pkg_pretend() {
# Verify OSS support
if use oss; then
if ! has_version ">=media-sound/oss-4"; then
- eerror "You cannot build wine with USE=oss without having support from a"
- eerror "FreeBSD kernel or >=media-sound/oss-4 (only available through external repos)"
+ eerror "You cannot build wine with USE=oss without having support from"
+ eerror ">=media-sound/oss-4 (only available through external repos)"
eerror
die
fi