summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/wine-staging/wine-staging-9999.ebuild')
-rw-r--r--app-emulation/wine-staging/wine-staging-9999.ebuild33
1 files changed, 31 insertions, 2 deletions
diff --git a/app-emulation/wine-staging/wine-staging-9999.ebuild b/app-emulation/wine-staging/wine-staging-9999.ebuild
index 11363b6b82bf..df834fec4d88 100644
--- a/app-emulation/wine-staging/wine-staging-9999.ebuild
+++ b/app-emulation/wine-staging/wine-staging-9999.ebuild
@@ -44,7 +44,7 @@ fi
LICENSE="LGPL-2.1"
SLOT="${PV}"
-IUSE="+abi_x86_32 +abi_x86_64 +alsa capi cups custom-cflags dos elibc_glibc +faudio +fontconfig +gcrypt +gecko gphoto2 gsm gssapi gstreamer +jpeg kerberos kernel_FreeBSD +lcms ldap +mono mp3 ncurses netapi nls odbc openal opencl +opengl osmesa oss +perl pcap pipelight +png prelink pulseaudio +realtime +run-exes samba scanner sdl selinux +ssl staging test themes +threads +truetype udev +udisks +unwind v4l vaapi vkd3d vulkan +X +xcomposite xinerama +xml"
+IUSE="+abi_x86_32 +abi_x86_64 +alsa capi cups custom-cflags dos elibc_glibc +faudio +fontconfig +gcrypt +gecko gphoto2 gsm gssapi gstreamer +jpeg kerberos kernel_FreeBSD +lcms ldap mingw +mono mp3 ncurses netapi nls odbc openal opencl +opengl osmesa oss +perl pcap pipelight +png prelink pulseaudio +realtime +run-exes samba scanner sdl selinux +ssl staging test themes +threads +truetype udev +udisks +unwind v4l vaapi vkd3d vulkan +X +xcomposite xinerama +xml"
REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )
X? ( truetype )
elibc_glibc? ( threads )
@@ -297,6 +297,34 @@ pkg_pretend() {
die
fi
fi
+
+ if use mingw && use abi_x86_32 && ! has_version "cross-i686-w64-mingw32/gcc"; then
+ eerror
+ eerror "USE=\"mingw\" is currently experimental, and requires the"
+ eerror "'cross-i686-w64-mingw32' compiler and its runtime for 32-bit builds."
+ eerror
+ eerror "These can be installed by using 'sys-devel/crossdev':"
+ eerror
+ eerror "crossdev --target i686-w64-mingw32"
+ eerror
+ eerror "For more information on setting up MinGW, see: https://wiki.gentoo.org/wiki/Mingw"
+ eerror
+ die "MinGW build was enabled, but no compiler to support it was found."
+ fi
+
+ if use mingw && use abi_x86_64 && ! has_version "cross-x86_64-w64-mingw32/gcc"; then
+ eerror
+ eerror "USE=\"mingw\" is currently experimental, and requires the"
+ eerror "'cross-x86_64-w64-mingw32' compiler and its runtime for 64-bit builds."
+ eerror
+ eerror "These can be installed by using 'sys-devel/crossdev':"
+ eerror
+ eerror "crossdev --target x86_64-w64-mingw32"
+ eerror
+ eerror "For more information on setting up MinGW, see: https://wiki.gentoo.org/wiki/Mingw"
+ eerror
+ die "MinGW build was enabled, but no compiler to support it was found."
+ fi
}
pkg_setup() {
@@ -455,7 +483,8 @@ multilib_src_configure() {
$(use_with jpeg)
$(use_with kerberos krb5)
$(use_with ldap)
- --without-mingw # linux LDFLAGS leak in mingw32: bug #685172
+ # TODO: Will bug 685172 still need special handling?
+ $(use_with mingw)
$(use_enable mono mscoree)
$(use_with mp3 mpg123)
$(use_with netapi)