summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/wine/wine-1.9.6-r3.ebuild')
-rw-r--r--app-emulation/wine/wine-1.9.6-r3.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/app-emulation/wine/wine-1.9.6-r3.ebuild b/app-emulation/wine/wine-1.9.6-r3.ebuild
index 186ee04c6675..fcfa5a0d7c2c 100644
--- a/app-emulation/wine/wine-1.9.6-r3.ebuild
+++ b/app-emulation/wine/wine-1.9.6-r3.ebuild
@@ -487,8 +487,10 @@ multilib_src_install_all() {
if ! use X && ! use ncurses; then
rm "${D}"/usr/bin/wineconsole* || die
rm "${D}"/usr/share/man/man1/wineconsole* || die
- use abi_x86_32 && rm "${D}"/usr/lib32/wine/{,fakedlls/}wineconsole.exe* || die
- use abi_x86_64 && rm "${D}"/usr/lib64/wine/{,fakedlls/}wineconsole.exe* || die
+ rm_wineconsole() {
+ rm "${D}usr/$(get_libdir)"/wine/{,fakedlls/}wineconsole.exe* || die
+ }
+ multilib_foreach_abi rm_wineconsole
fi
use abi_x86_32 && pax-mark psmr "${D}"usr/bin/wine{,-preloader} #255055