summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/winetricks')
-rw-r--r--app-emulation/winetricks/Manifest1
-rw-r--r--app-emulation/winetricks/winetricks-20170823.ebuild2
-rw-r--r--app-emulation/winetricks/winetricks-20171222.ebuild96
-rw-r--r--app-emulation/winetricks/winetricks-99999999.ebuild26
4 files changed, 117 insertions, 8 deletions
diff --git a/app-emulation/winetricks/Manifest b/app-emulation/winetricks/Manifest
index 0325004968d4..2c9216f39b22 100644
--- a/app-emulation/winetricks/Manifest
+++ b/app-emulation/winetricks/Manifest
@@ -1,2 +1,3 @@
DIST winetricks-20170823.tar.gz 639027 BLAKE2B ce0de22ff3363bd6fd675d07ea235ed5fb03ea7a84b3242329c094d6a9190c61813a1f360e74ece49d43d2dbf48dbbb1e94c4febc6e1a0d84cf1df895b0be6f9 SHA512 edc805be1a1c4fa64ae16b14fdd46786e259b88a0cde7afdf24bf934fa79f4acf3d9e599727fa589f155ec265569953b9e419cda79d54057157cbb1510261e3a
+DIST winetricks-20171222.tar.gz 645227 BLAKE2B b3d798071593851eb7293270ab40438f114576c58e9c4df2ec685192a1eb1b2f8fbbb9d71a7575472575d56941a6fdeb1b7b2c33e87e0e40885ba8489764c392 SHA512 fcee2dcac4c68a2c8f61995146d83a81ee85364e400ceadfed1ae1a6f49ea389a6d044fc9ae2324dbbaf93ec3eb616ab167ed880b1a583e89708cf66fb8c5965
DIST winetricks-gentoo-2012.11.24.tar.bz2 6398 BLAKE2B 54a4502f6e8ef15d21b02c43e3ce599e32d476c2559246064de14cc4ce2243ff11dde681d24c8a7f4913c3d7a10b855bda47e8fb8ecad31e00d839705416be6f SHA512 59c93b73f3a7b2d11aefcde2ff66659ff1de21ad4b5f232f4b60572f3a48b15a6c49f369b1696862bf1b33fde190bf5598945e9536fb41ddec42d8def4d2be2a
diff --git a/app-emulation/winetricks/winetricks-20170823.ebuild b/app-emulation/winetricks/winetricks-20170823.ebuild
index 33701ee6fa54..111786b25a30 100644
--- a/app-emulation/winetricks/winetricks-20170823.ebuild
+++ b/app-emulation/winetricks/winetricks-20170823.ebuild
@@ -32,8 +32,8 @@ RDEPEND="app-arch/cabextract
app-arch/p7zip
app-arch/unzip
net-misc/wget
- x11-misc/xdg-utils
virtual/wine
+ x11-misc/xdg-utils
gtk? ( gnome-extra/zenity )
kde? ( kde-apps/kdialog )
rar? ( app-arch/unrar )"
diff --git a/app-emulation/winetricks/winetricks-20171222.ebuild b/app-emulation/winetricks/winetricks-20171222.ebuild
new file mode 100644
index 000000000000..58d2e71829ba
--- /dev/null
+++ b/app-emulation/winetricks/winetricks-20171222.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils eutils
+
+if [[ ${PV} == "99999999" ]] ; then
+ EGIT_REPO_URI="https://github.com/Winetricks/${PN}.git"
+ inherit git-r3
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/Winetricks/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+wtg=winetricks-gentoo-2012.11.24
+
+SRC_URI="${SRC_URI}
+ gtk? ( https://dev.gentoo.org/~tetromino/distfiles/wine/${wtg}.tar.bz2 )
+ kde? ( https://dev.gentoo.org/~tetromino/distfiles/wine/${wtg}.tar.bz2 )"
+
+DESCRIPTION="Easy way to install DLLs needed to work around problems in Wine"
+HOMEPAGE="https://github.com/Winetricks/winetricks https://wiki.winehq.org/Winetricks"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="gtk kde rar test"
+
+DEPEND="test? (
+ dev-python/bashate
+ dev-util/checkbashisms
+ dev-util/shellcheck
+ )"
+
+RDEPEND="app-arch/cabextract
+ app-arch/p7zip
+ app-arch/unzip
+ net-misc/wget
+ virtual/wine
+ x11-misc/xdg-utils
+ gtk? ( gnome-extra/zenity )
+ kde? ( kde-apps/kdialog )
+ rar? ( app-arch/unrar )"
+
+# Test targets include syntax checks only, not the "heavy duty" tests
+# that would require a lot of disk space, as well as network access.
+
+# This uses a non-standard "Wine" category, which is provided by
+# '/etc/xdg/menus/applications-merged/wine.menu' from the
+# 'app-emulation/wine-desktop-common' package.
+# https://bugs.gentoo.org/451552
+QA_DESKTOP_FILE="usr/share/applications/winetricks.desktop"
+
+src_unpack() {
+ if [[ ${PV} == "99999999" ]] ; then
+ git-r3_src_unpack
+ if use gtk || use kde; then
+ unpack ${wtg}.tar.bz2
+ fi
+ else
+ default
+ fi
+}
+
+src_test() {
+ ./tests/shell-checks || die "Test(s) failed."
+}
+
+src_install() {
+ default
+ if use gtk || use kde; then
+ cd "${WORKDIR}/${wtg}" || die
+ domenu winetricks.desktop
+ insinto /usr/share/icons/hicolor/scalable/apps
+ doins wine-winetricks.svg
+ fi
+}
+
+pkg_preinst() {
+ if use gtk || use kde; then
+ gnome2_icon_savelist
+ fi
+}
+
+pkg_postinst() {
+ if use gtk || use kde; then
+ gnome2_icon_cache_update
+ fi
+}
+
+pkg_postrm() {
+ if use gtk || use kde; then
+ gnome2_icon_cache_update
+ fi
+}
diff --git a/app-emulation/winetricks/winetricks-99999999.ebuild b/app-emulation/winetricks/winetricks-99999999.ebuild
index c6636ccbdade..58d2e71829ba 100644
--- a/app-emulation/winetricks/winetricks-99999999.ebuild
+++ b/app-emulation/winetricks/winetricks-99999999.ebuild
@@ -25,24 +25,32 @@ HOMEPAGE="https://github.com/Winetricks/winetricks https://wiki.winehq.org/Winet
LICENSE="LGPL-2.1+"
SLOT="0"
-IUSE="gtk kde rar"
+IUSE="gtk kde rar test"
+
+DEPEND="test? (
+ dev-python/bashate
+ dev-util/checkbashisms
+ dev-util/shellcheck
+ )"
-DEPEND=""
RDEPEND="app-arch/cabextract
app-arch/p7zip
app-arch/unzip
net-misc/wget
- x11-misc/xdg-utils
virtual/wine
+ x11-misc/xdg-utils
gtk? ( gnome-extra/zenity )
kde? ( kde-apps/kdialog )
rar? ( app-arch/unrar )"
-# Uses non-standard "Wine" category, which is provided by app-emulation/wine; #451552
-QA_DESKTOP_FILE="usr/share/applications/winetricks.desktop"
+# Test targets include syntax checks only, not the "heavy duty" tests
+# that would require a lot of disk space, as well as network access.
-# Tests require network access and run Wine, which is unreliable from a portage environment.
-RESTRICT="test"
+# This uses a non-standard "Wine" category, which is provided by
+# '/etc/xdg/menus/applications-merged/wine.menu' from the
+# 'app-emulation/wine-desktop-common' package.
+# https://bugs.gentoo.org/451552
+QA_DESKTOP_FILE="usr/share/applications/winetricks.desktop"
src_unpack() {
if [[ ${PV} == "99999999" ]] ; then
@@ -55,6 +63,10 @@ src_unpack() {
fi
}
+src_test() {
+ ./tests/shell-checks || die "Test(s) failed."
+}
+
src_install() {
default
if use gtk || use kde; then