summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/uxn/Manifest1
-rw-r--r--app-emulation/uxn/uxn-0_p20221211.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-emulation/uxn/Manifest b/app-emulation/uxn/Manifest
index c35bd8ef8072..c423798e8140 100644
--- a/app-emulation/uxn/Manifest
+++ b/app-emulation/uxn/Manifest
@@ -1,3 +1,4 @@
DIST uxn-0_p20220815.tar.gz 286763 BLAKE2B d50e52da1614fdd2939ad09d5c372c103cbfa074b10e1a17560baa3ad5e09a81b9627efdc5f17c7572798d06f1e6a388cb473348950cef5ba45c7d40b3716ec6 SHA512 237c6d633783006d8503b6b4726aaa1d8ed22209c0c6368e78a3da0703d92cb8b1e9c5c7372faecc374082be56608ac1857efc0629e0dff6e374a2adbf1d20ea
DIST uxn-0_p20220921.tar.gz 286803 BLAKE2B 98230eec1f5071451a25dbe0136f3fd2d7e9ad08287df40bef611ae3012e3775d787a653a43fb4f1cb6c8f213cb8d39684e48c4f6c225bc19e86f1e4b94d73ba SHA512 8568114ddd98672aab4ca59ab279d39ff7a30c04d0b2a53da85b342a17a80d82b5b0ab90f04f63aa0491f8feaa91655f8fa725ec0d76a559b6201407b47bf1f5
DIST uxn-0_p20221022.tar.gz 287106 BLAKE2B 3ca3f1363a71c2c974e95c75cba09d13ff81f320e1ec5ecf3b9a93de6d834447105fd49aa04c0c94a53f01a79bfda68f24662c7eac3993937d9870e5fd7dd4f6 SHA512 77fa297cdd02856cc1a6ddd4515f459d77e216434319a3e7901598d1c28dc34fe49429ae6875745f412bbc977c44041c2c65dc5d0dc4fdb25708e8e666995d81
+DIST uxn-0_p20221211.tar.gz 284943 BLAKE2B de116e87120bc71975271c9ad0c1b01cba6e13a78cba0faaf811a2cace72204f15fca620bb4c87518542208e1c2af49e6db98b1b3b442ec3a855fb8b592acb2d SHA512 d59504f994b487aff151fefdb2f0f87a707fe998c1ea08539dc8d67aed28a4c93c9ff4bde036a9eb44401e8e6a12b7a15c17e434d5cab7b44a17e2e18e50e978
diff --git a/app-emulation/uxn/uxn-0_p20221211.ebuild b/app-emulation/uxn/uxn-0_p20221211.ebuild
new file mode 100644
index 000000000000..0733343327a1
--- /dev/null
+++ b/app-emulation/uxn/uxn-0_p20221211.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=6317b5cf181e56253da10e0e5051ac75bbb5c4b2
+
+inherit toolchain-funcs
+
+DESCRIPTION="An assembler and emulator for the Uxn stack-machine, written in ANSI C"
+HOMEPAGE="https://wiki.xxiivv.com/site/uxn.html
+ https://git.sr.ht/~rabbits/uxn/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.sr.ht/~rabbits/uxn.git"
+else
+ SRC_URI="https://git.sr.ht/~rabbits/uxn/archive/${H}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${H}
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="media-libs/libsdl2:="
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/uxn-build.sh.patch )
+
+src_compile() {
+ CC="$(tc-getCC)" CFLAGS="${CFLAGS} ${LDFLAGS}" ./build.sh --no-run ||
+ die "build failed"
+
+ local f
+ for f in ./projects/{examples/*,software,utils}/*.tal ; do
+ ./bin/uxnasm "${f}" "$(dirname "${f}")"/"$(basename "${f}" .tal)".rom ||
+ die "failed to assemble ${f}"
+ done
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe bin/uxn*
+
+ insinto /usr/share/uxn
+ doins bin/*.rom
+ doins -r projects
+
+ einstalldocs
+}