summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.11-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.11-r1.ebuild b/app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.11-r1.ebuild
new file mode 100644
index 000000000000..1a4184f43e45
--- /dev/null
+++ b/app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.11-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Scripts to build Ganeti VMs with debootstrap"
+HOMEPAGE="http://www.ganeti.org/"
+SRC_URI="https://ganeti.googlecode.com/files/ganeti-instance-debootstrap-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-arch/dpkg
+ app-arch/dump
+ app-emulation/ganeti
+ dev-util/debootstrap
+ >=sys-apps/coreutils-6.10-r1
+ sys-apps/util-linux
+ sys-fs/e2fsprogs"
+
+src_configure() {
+ econf --docdir=/usr/share/doc/${P}
+}
+
+src_install() {
+ default
+ insinto /etc/ganeti/instance-debootstrap/hooks
+ doins examples/hooks/*
+}