summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/libspectrum/files/remove-local-prefix.patch18
-rw-r--r--app-emulation/libspectrum/libspectrum-1.4.4.ebuild11
2 files changed, 29 insertions, 0 deletions
diff --git a/app-emulation/libspectrum/files/remove-local-prefix.patch b/app-emulation/libspectrum/files/remove-local-prefix.patch
new file mode 100644
index 000000000000..23e2b5dd041c
--- /dev/null
+++ b/app-emulation/libspectrum/files/remove-local-prefix.patch
@@ -0,0 +1,18 @@
+diff -Naur libspectrum-1.4.4/configure.ac libspectrum-1.4.4-patched/configure.ac
+--- libspectrum-1.4.4/configure.ac 2018-07-01 02:07:44.000000000 +0200
++++ libspectrum-1.4.4-patched/configure.ac 2020-07-28 16:38:22.636459194 +0200
+@@ -113,14 +113,6 @@
+ dnl Check for functions
+ AC_CHECK_FUNCS(_snprintf _stricmp _strnicmp snprintf strcasecmp strncasecmp)
+
+-dnl Allow the user to say that various libraries are in one place
+-AC_ARG_WITH(local-prefix,
+-[ --with-local-prefix=PFX local libraries installed in PFX (optional)],
+-CPPFLAGS="$CPPFLAGS -I$withval/include"; LDFLAGS="$LDFLAGS -L$withval/lib",
+-if test "$prefix" != "NONE"; then
+- CPPFLAGS="$CPPFLAGS -I$prefix/include"; LDFLAGS="$LDFLAGS -L$prefix/lib"
+-fi)
+-
+ dnl Check whether to use zlib (the UNIX version is called z, Win32 zdll)
+ AC_MSG_CHECKING(whether to use zlib)
+ AC_ARG_WITH(zlib,
diff --git a/app-emulation/libspectrum/libspectrum-1.4.4.ebuild b/app-emulation/libspectrum/libspectrum-1.4.4.ebuild
index 7d6cd415f46a..f830494fd23b 100644
--- a/app-emulation/libspectrum/libspectrum-1.4.4.ebuild
+++ b/app-emulation/libspectrum/libspectrum-1.4.4.ebuild
@@ -3,6 +3,8 @@
EAPI=6
+inherit autotools
+
DESCRIPTION="Spectrum emulation library"
HOMEPAGE="http://fuse-emulator.sourceforge.net/libspectrum.php"
SRC_URI="mirror://sourceforge/fuse-emulator/${P}.tar.gz"
@@ -21,6 +23,15 @@ DEPEND="${RDEPEND}
dev-lang/perl
virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}"/remove-local-prefix.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
local myconf=(
--disable-static