summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-eselect/eselect-QtPy/eselect-QtPy-1.0.ebuild')
-rw-r--r--app-eselect/eselect-QtPy/eselect-QtPy-1.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-eselect/eselect-QtPy/eselect-QtPy-1.0.ebuild b/app-eselect/eselect-QtPy/eselect-QtPy-1.0.ebuild
new file mode 100644
index 000000000000..5987bee82fbb
--- /dev/null
+++ b/app-eselect/eselect-QtPy/eselect-QtPy-1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Manage Qt for Python implementations"
+HOMEPAGE="https://github.com/spyder-ide/qtpy"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="app-admin/eselect"
+
+S="${FILESDIR}"
+
+src_install() {
+ insinto "/usr/share/eselect/modules"
+ newins "qtpy.eselect-${PV}" "qtpy.eselect"
+}
+
+pkg_postinst() {
+ eselect qtpy update
+}