summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-eselect/eselect-pinentry')
-rw-r--r--app-eselect/eselect-pinentry/eselect-pinentry-0.7.3.ebuild20
-rw-r--r--app-eselect/eselect-pinentry/files/pinentry.eselect-0.7.319
2 files changed, 39 insertions, 0 deletions
diff --git a/app-eselect/eselect-pinentry/eselect-pinentry-0.7.3.ebuild b/app-eselect/eselect-pinentry/eselect-pinentry-0.7.3.ebuild
new file mode 100644
index 000000000000..b7fd5011efb3
--- /dev/null
+++ b/app-eselect/eselect-pinentry/eselect-pinentry-0.7.3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Manage /usr/bin/pinentry symlink"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Eselect"
+S="${WORKDIR}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND=">=app-eselect/eselect-lib-bin-symlink-0.1.1"
+
+src_install() {
+ default
+ insinto /usr/share/eselect/modules
+ newins "${FILESDIR}"/pinentry.eselect-${PV} pinentry.eselect
+}
diff --git a/app-eselect/eselect-pinentry/files/pinentry.eselect-0.7.3 b/app-eselect/eselect-pinentry/files/pinentry.eselect-0.7.3
new file mode 100644
index 000000000000..bc058bb41ee7
--- /dev/null
+++ b/app-eselect/eselect-pinentry/files/pinentry.eselect-0.7.3
@@ -0,0 +1,19 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+DESCRIPTION="Manage /usr/bin/pinentry implementation"
+MAINTAINER="maintainer-needed@gentoo.org"
+VERSION="0.7.3"
+
+SYMLINK_PATH=/usr/bin/pinentry
+SYMLINK_TARGETS=(
+ pinentry-efl
+ pinentry-gnome3
+ pinentry-qt5
+ pinentry-curses
+ pinentry-tty
+ pinentry-emacs
+)
+SYMLINK_DESCRIPTION='pinentry binary'
+
+inherit bin-symlink