summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/aflplusplus/Manifest2
-rw-r--r--app-forensics/aflplusplus/aflplusplus-4.06c.ebuild87
2 files changed, 89 insertions, 0 deletions
diff --git a/app-forensics/aflplusplus/Manifest b/app-forensics/aflplusplus/Manifest
index 90512a2f7a66..4bfecf350b20 100644
--- a/app-forensics/aflplusplus/Manifest
+++ b/app-forensics/aflplusplus/Manifest
@@ -4,3 +4,5 @@ DIST aflplusplus-4.04c-patches.tar.xz 4236 BLAKE2B 86bb5d1e0da271833fc548633e088
DIST aflplusplus-4.04c.tar.gz 2832011 BLAKE2B 80a5652b0d64b4824c3b4f91bf993a8499a0c86cf878ca83c7b7afe217cc1603700d4cf7408ae40f1435251153f88e0663cabe470a06387e6664249b3a015172 SHA512 1c2e2e6677e87de2f069e1acdc2319580e488670c3d4975a0f0807da33965c4a14087a7c734195d0a47260acc91f7211b10bd905aac99bdab81145b282edb44e
DIST aflplusplus-4.05c-patches.tar.xz 4860 BLAKE2B dcc0bf2799393bb7e27c6592cf46efc19277733ae1e17b3ab5b7a60aed244ec24405ceaecb5f310ac344390a92b4348275e8a19936b8760c0f2fe74f086771b9 SHA512 7a475f433796d9b9c13c5755a11aa632174662d18e69add6531fe1cbe42d75ad514bc779e42630b0a48c9df9edcc89fe992f654812fa2281b6ffa64a1019c82c
DIST aflplusplus-4.05c.tar.gz 2839704 BLAKE2B 31594e5c41cb057a1598a112e158360a172a512756a2cba2ec9bd78643045945c9a0f378e322c9250e75a6348b76f5cc84d8de6560e0a6a92a19f4d4b9a149eb SHA512 cb07279e4b1b2fa48a455acd551e26d9a53cf585258880aba4f26aa147b748b947b0608e5bbec4212362da3efc20183ba90b2dfa6584df93861dcca269d5ea7c
+DIST aflplusplus-4.06c-patches.tar.xz 4360 BLAKE2B fb59065ef610e87d8bc822513822c150b592e0cdcf4f8f2d861b5dc4a5ded49a03b4ccc46636e24d69bdcee58f6882511f25a04cbc02565f9435c47be1b0829f SHA512 251db964ce6c7e1f59c6c1a8383c1fe4d362c7d336df4d13f0bc1f3c8583494e2b9c9f160fdd544174cc784afc1ae100310109d0d6a30c361b82f3ab50350afa
+DIST aflplusplus-4.06c.tar.gz 2859398 BLAKE2B bf26d6be364d01f91a5b60e2bca1ab48e2fed04571bbaee2fd74c31af1c3d53295808c5372bda8dc941232349e9113e09f2d0e8cadc5917fc4fc52e24bad9d60 SHA512 b585b244218e70e1120a81a5fbb7401d277174be13c5d5d507130ff7a7b25723ff29c2b3c820466ba847ff53ef016b23781edaccdfcdce904f6b93ec4d860140
diff --git a/app-forensics/aflplusplus/aflplusplus-4.06c.ebuild b/app-forensics/aflplusplus/aflplusplus-4.06c.ebuild
new file mode 100644
index 000000000000..2d81610f1f76
--- /dev/null
+++ b/app-forensics/aflplusplus/aflplusplus-4.06c.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+LLVM_MAX_SLOT=16
+inherit toolchain-funcs llvm optfeature python-single-r1
+
+AFL_PATCHSET="${PN}-4.06c-patches"
+DESCRIPTION="A fork of AFL, the popular compile-time instrumentation fuzzer"
+HOMEPAGE="https://github.com/AFLplusplus/AFLplusplus"
+SRC_URI="https://github.com/AFLplusplus/AFLplusplus/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${AFL_PATCHSET}.tar.xz"
+S="${WORKDIR}"/AFLplusplus-${PV}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Tests involve heavy use of LD_PRELOAD in some cases
+# This isn't compatible with sandbox
+RESTRICT="test"
+
+# It turns out we need Clang too
+RDEPEND="${PYTHON_DEPS}
+ >=sys-devel/llvm-13:=
+ || (
+ sys-devel/clang:13
+ sys-devel/clang:14
+ sys-devel/clang:${LLVM_MAX_SLOT}
+ )
+ !app-forensics/afl"
+DEPEND="${RDEPEND}
+ test? ( dev-util/cmocka )"
+
+QA_FLAGS_IGNORED="afl-gcc-cmplog-pass.so afl-gcc-cmptrs-pass.so"
+QA_PREBUILT="usr/share/afl/testcases/others/elf/small_exec.elf"
+
+PATCHES=(
+ "${WORKDIR}"/${AFL_PATCHSET}
+)
+
+llvm_check_deps() {
+ has_version -b "sys-devel/clang:${LLVM_SLOT}" && \
+ has_version -b "sys-devel/llvm:${LLVM_SLOT}"
+}
+
+pkg_setup() {
+ llvm_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+mymake() {
+ emake \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ CFLAGS_FLTO="" \
+ LLVM_CONFIG="$(get_llvm_prefix ${LLVM_MAX_SLOT})"/bin/llvm-config \
+ PREFIX="${EPREFIX}/usr" \
+ HELPER_PATH="${EPREFIX}/usr/$(get_libdir)/afl" \
+ DOC_PATH="${EPREFIX}/usr/share/doc/${PF}" \
+ MAN_PATH="${EPREFIX}/usr/share/man/man8" \
+ "$@"
+}
+
+src_compile() {
+ mymake
+}
+
+src_test() {
+ mymake test
+}
+
+src_install() {
+ mymake DESTDIR="${D}" install
+ dostrip -x /usr/share/afl/testcases/
+}
+
+pkg_postinst() {
+ # TODO: Any others?
+ optfeature "fuzzing with AFL_USE_ASAN" sys-libs/compiler-rt-sanitizers[asan]
+ optfeature "fuzzing with AFL_USE_MSAN" sys-libs/compiler-rt-sanitizers[msan]
+}