summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/canfep')
-rw-r--r--app-i18n/canfep/Manifest2
-rw-r--r--app-i18n/canfep/canfep-1.0-r1.ebuild45
-rw-r--r--app-i18n/canfep/canfep-1.0.ebuild39
-rw-r--r--app-i18n/canfep/files/canfep-posix-pty.patch67
-rw-r--r--app-i18n/canfep/files/canfep-termcap.patch266
-rw-r--r--app-i18n/canfep/metadata.xml8
6 files changed, 0 insertions, 427 deletions
diff --git a/app-i18n/canfep/Manifest b/app-i18n/canfep/Manifest
deleted file mode 100644
index 79bb1548a941..000000000000
--- a/app-i18n/canfep/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST canfep-1.0.tar.gz 8067 BLAKE2B 1a6e8af357d2b7aaccf442b0f8bab577ed05a5a0fdf2fb4c189105c2c41f739c2e559e740584bf393fcc52d3f3bd0bb6216e06e2b685f62f7dded9d576e95bed SHA512 0fd7c8ca56282fa537b76fe33f46e03d4f0f4727528ccad95cd4726888372da9158fc8bed2cdc67d645defb479040cd4a4d0999f69d38fd8b4080f7ece4e67d6
-DIST canfep_utf8.diff 7152 BLAKE2B e3848d5119b01d3296c93b5ed8495c6f93ecb1ef39f168d6e1685636055295b8f7277c6b680cadb648fe6847c92e3b038a9b5a9a58f23fe3490dcbe675bcc96f SHA512 32d946b8b78efd3b95736738497fe46a7d0e2383f2b665c8af79270d7b0d1404ca051e63fc67375f0b953b8f604475c8d6b2d683089bc97b098fa9524b89208c
diff --git a/app-i18n/canfep/canfep-1.0-r1.ebuild b/app-i18n/canfep/canfep-1.0-r1.ebuild
deleted file mode 100644
index c78e54ada07f..000000000000
--- a/app-i18n/canfep/canfep-1.0-r1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit toolchain-funcs
-
-DESCRIPTION="Canna Japanese kana-kanji frontend processor on console"
-#HOMEPAGE="http://www.geocities.co.jp/SiliconValley-Bay/7584/canfep/"
-HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
-SRC_URI="mirror://gentoo/${P}.tar.gz
- unicode? ( http://hp.vector.co.jp/authors/VA020411/patches/${PN}_utf8.diff )"
-
-LICENSE="canfep"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~ppc ~sparc x86"
-IUSE="unicode"
-
-RDEPEND="app-i18n/canna
- sys-libs/ncurses:="
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-posix-pty.patch
- "${FILESDIR}"/${PN}-termcap.patch
-)
-
-src_prepare() {
- use unicode && eapply "${DISTDIR}"/${PN}_utf8.diff
- sed -i 's/$(CFLAGS)/$(CFLAGS) $(LDFLAGS)/' Makefile
-
- default
-}
-
-src_compile() {
- emake \
- CC="$(tc-getCXX)" \
- LIBS="-lcanna $($(tc-getPKG_CONFIG) --libs ncurses)"
-}
-
-src_install() {
- dobin ${PN}
- dodoc 00{changes,readme}
-}
diff --git a/app-i18n/canfep/canfep-1.0.ebuild b/app-i18n/canfep/canfep-1.0.ebuild
deleted file mode 100644
index a290748825da..000000000000
--- a/app-i18n/canfep/canfep-1.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit toolchain-funcs
-
-DESCRIPTION="Canna Japanese kana-kanji frontend processor on console"
-HOMEPAGE="http://www.geocities.co.jp/SiliconValley-Bay/7584/canfep/"
-SRC_URI="http://www.geocities.co.jp/SiliconValley-Bay/7584/${PN}/${P}.tar.gz
- unicode? ( http://hp.vector.co.jp/authors/VA020411/patches/${PN}_utf8.diff )"
-
-LICENSE="canfep"
-SLOT="0"
-KEYWORDS="-alpha ~amd64 ppc ~sparc x86"
-IUSE="unicode"
-
-RDEPEND="app-i18n/canna
- sys-libs/ncurses:="
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- use unicode && eapply "${DISTDIR}"/${PN}_utf8.diff
- sed -i 's/$(CFLAGS)/$(CFLAGS) $(LDFLAGS)/' Makefile
-
- default
-}
-
-src_compile() {
- emake \
- CC="$(tc-getCXX)" \
- LIBS="-lcanna $(pkg-config --libs ncurses)"
-}
-
-src_install() {
- dobin ${PN}
- dodoc 00{changes,readme}
-}
diff --git a/app-i18n/canfep/files/canfep-posix-pty.patch b/app-i18n/canfep/files/canfep-posix-pty.patch
deleted file mode 100644
index caa451232ef4..000000000000
--- a/app-i18n/canfep/files/canfep-posix-pty.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-https://bugs.gentoo.org/show_bug.cgi?id=212709
-
-Author: OKUMURA N. Shin-ya <oku.ns@dream.com>
-
---- a/pty.C
-+++ b/pty.C
-@@ -257,6 +257,23 @@
- }
- }
-
-+#if defined(_POSIX_C_SOURCE)
-+ // BSD pty が開けないので、POSIX の方法を試す
-+ if ((master = posix_openpt(O_RDWR)) >= 0) {
-+ if (grantpt(master) == 0 && unlockpt(master) == 0) {
-+ // マスタデバイス名は固定
-+ strcpy(line, "/dev/ptmx");
-+ tcgetattr(0, &tt);
-+ tt.c_iflag &= ~ISTRIP;
-+ ioctl(0, TIOCGWINSZ, (char*) &win);
-+ return;
-+ }
-+ close(master);
-+ } else {
-+ perror("/dev/ptmx");
-+ }
-+#endif // _POSIX_C_SOURCE
-+
- printf("Out of pty's\n");
- fail();
- }
-@@ -265,12 +282,36 @@
- void
- Pty::getslave()
- {
-+#if defined(_POSIX_C_SOURCE)
-+ // マスタデバイスが POSIX 方式の場合
-+ if (strcmp(line, "/dev/ptmx") == 0) {
-+ char *slave_devname = ptsname(master);
-+ if (slave_devname == NULL) {
-+ perror("ptsname");
-+ fail();
-+ }
-+ slave = open(slave_devname, O_RDWR);
-+ if (slave < 0) {
-+ perror(slave_devname);
-+ fail();
-+ }
-+ strcpy(line, slave_devname);
-+ } else {
-+ line[strlen("/dev/")] = 't';
-+ slave = open(line, O_RDWR);
-+ if (slave < 0) {
-+ perror(line);
-+ fail();
-+ }
-+ }
-+#else // ! _POSIX_C_SOURCE
- line[strlen("/dev/")] = 't';
- slave = open(line, O_RDWR);
- if (slave < 0) {
- perror(line);
- fail();
- }
-+#endif // _POSIX_C_SOURCE
- tcsetattr(slave, TCSAFLUSH, &tt);
- if (!hs)
- win.ws_row--;
diff --git a/app-i18n/canfep/files/canfep-termcap.patch b/app-i18n/canfep/files/canfep-termcap.patch
deleted file mode 100644
index afd215b07e79..000000000000
--- a/app-i18n/canfep/files/canfep-termcap.patch
+++ /dev/null
@@ -1,266 +0,0 @@
---- a/pty.C
-+++ b/pty.C
-@@ -4,9 +4,18 @@
- int Pty::child = 0;
- struct termios Pty::tt;
- int Pty::wfd = 0;
-+char Pty::buf[] = "";
-+char Pty::funcstr[] = "";
- int Pty::hs = 0;
-+char* Pty::so = 0;
-+char* Pty::se = 0;
-+char* Pty::us = 0;
-+char* Pty::ue = 0;
-+char* Pty::sc = 0;
-+char* Pty::rc = 0;
- char* Pty::ce = 0;
- char* Pty::ts = 0;
-+char* Pty::fs = 0;
- char* Pty::ds = 0;
- char Pty::endstr[] = "";
- char Pty::endmsg[] = "";
-@@ -14,88 +23,7 @@
- // コンストラクタだよん
- Pty::Pty(int ac, char** av, char* amsg, char* emsg)
- {
-- // 環境変数 TERM のエントリを取得
-- char buff[BUFSIZ];
-- char* term = getenv("TERM");
-- if (!term)
-- term = "vt100";
-- int ret = tgetent(buff, term);
-- if (ret != 1) {
-- tgetent(buff, "vt100");
-- putenv("TERM=vt100");
-- }
--
-- // termcap から装飾用のエントリを取ってくる
-- char funcstr[BUFSIZ];
-- char* pt = funcstr;
--
-- // スタンドアウト (反転)
-- so = tgetstr("so", &pt);
-- adjstr(so);
-- se = tgetstr("se", &pt);
-- adjstr(se);
--
-- // アンダーライン (下線)
-- us = tgetstr("us", &pt);
-- adjstr(us);
-- ue = tgetstr("ue", &pt);
-- adjstr(ue);
--
-- // カーソル位置の保存,保存した位置への復帰
-- sc = tgetstr("sc", &pt);
-- adjstr(sc);
-- rc = tgetstr("rc", &pt);
-- adjstr(rc);
--
-- // カーソル位置から行の最後までを削除する
-- ce = tgetstr("ce", &pt);
-- adjstr(ce);
--
-- // ステータスラインを持っているかどうか
-- hs = tgetflag("hs");
--
-- // kon と jfbterm ではステータスラインを使わない
-- if (strcmp(term, "kon") == 0)
-- hs = 0;
-- if (strcmp(term, "jfbterm") == 0)
-- hs = 0;
--
-- // ステータスラインへ移動,戻る
-- if (hs) {
-- ts = tgoto(tgetstr("ts", &pt), 0, 0);
-- adjstr(ts);
-- fs = tgetstr("fs", &pt);
-- adjstr(fs);
-- ds = tgetstr("ds", &pt);
-- adjstr(ds);
-- if (ds) {
-- strcat(endstr, ds);
-- strcat(endstr, ce);
-- }
-- }
-- else {
-- char* cs = tgoto(tgetstr("cs", &pt), tgetnum("li") - 2, 0);
-- adjstr(cs);
-- if (cs) {
-- write(1, ce, strlen(ce));
-- write(1, cs, strlen(cs));
-- }
-- char* cl = tgetstr("cl", &pt);
-- adjstr(cl);
-- if (cl) {
-- write(1, cl, strlen(cl));
-- strcat(endstr, cl);
-- }
-- ds = tgoto(tgetstr("cs", &pt), tgetnum("li") - 1, 0);
-- adjstr(ds);
-- if (ds) {
-- strcat(endstr, ds);
-- strcat(endstr, ce);
-- }
-- ts = tgoto(tgetstr("cm", &pt), 0, tgetnum("li") - 1);
-- adjstr(ts);
-- fs = rc;
-- }
-+ gettermcap();
-
- // 開始と終了のメッセージ
- if (amsg && ac == 1)
-@@ -209,21 +137,75 @@
- done();
- }
-
--// termcap エントリからパディングを削除する
- void
--Pty::adjstr(char* str)
-+Pty::gettermcap()
- {
-- char* sp = strdup(str);
-- char* p = sp;
-- while (*p != '\0') {
-- if (strncmp(p, "$<", 2) == 0) {
-- while (*p != '>')
-- p++;
-- *p = '\0';
-+ // 環境変数 TERM のエントリを取得
-+ char* term = getenv("TERM");
-+ if (!term)
-+ term = "vt100";
-+ int ret = tgetent(buf, term);
-+ if (ret != 1) {
-+ tgetent(buf, "vt100");
-+ putenv("TERM=vt100");
-+ }
-+
-+ // termcap から装飾用のエントリを取ってくる
-+ char* pt = funcstr;
-+
-+ // スタンドアウト (反転)
-+ so = tgetstr("so", &pt);
-+ se = tgetstr("se", &pt);
-+
-+ // アンダーライン (下線)
-+ us = tgetstr("us", &pt);
-+ ue = tgetstr("ue", &pt);
-+
-+ // カーソル位置の保存,保存した位置への復帰
-+ sc = tgetstr("sc", &pt);
-+ rc = tgetstr("rc", &pt);
-+
-+ // カーソル位置から行の最後までを削除する
-+ ce = tgetstr("ce", &pt);
-+
-+ // ステータスラインを持っているかどうか
-+ hs = tgetflag("hs");
-+
-+ // kon と jfbterm ではステータスラインを使わない
-+ if (strcmp(term, "kon") == 0)
-+ hs = 0;
-+ if (strcmp(term, "jfbterm") == 0)
-+ hs = 0;
-+
-+ // ステータスラインへ移動,戻る
-+ if (hs) {
-+ ts = tgoto(tgetstr("ts", &pt), 0, 0);
-+ fs = tgetstr("fs", &pt);
-+ ds = tgetstr("ds", &pt);
-+ if (ds) {
-+ strcat(endstr, ds);
-+ strcat(endstr, ce);
- }
-- *str++ = *p++;
- }
-- free(sp);
-+ else {
-+ char* cs = tgoto(tgetstr("cs", &pt), tgetnum("li") - 2, 0);
-+ if (cs) {
-+ write(1, ce, strlen(ce));
-+ write(1, cs, strlen(cs));
-+ }
-+ char* cl = tgetstr("cl", &pt);
-+ if (cl) {
-+ write(1, cl, strlen(cl));
-+ strcat(endstr, cl);
-+ }
-+ ds = tgoto(tgetstr("cs", &pt), tgetnum("li") - 1, 0);
-+ if (ds) {
-+ strcat(endstr, ds);
-+ strcat(endstr, ce);
-+ }
-+ ts = tgoto(tgetstr("cm", &pt), 0, tgetnum("li") - 1);
-+ fs = rc;
-+ }
- }
-
- // マスタデバイスを取る
-@@ -327,34 +309,7 @@
- {
- signal(SIGWINCH, SIG_IGN);
-
-- // ステータスラインが使えない場合は cs/ds/ts を取り直す
-- if (!hs) {
-- char buff[BUFSIZ];
-- char* term = getenv("TERM");
-- tgetent(buff, term);
-- char funcstr[BUFSIZ];
-- char* pt = funcstr;
-- char* cs = tgoto(tgetstr("cs", &pt), tgetnum("li") - 2, 0);
-- adjstr(cs);
-- if (cs) {
-- write(1, ce, strlen(ce));
-- write(1, cs, strlen(cs));
-- }
-- char* cl = tgetstr("cl", &pt);
-- adjstr(cl);
-- if (cl) {
-- write(1, cl, strlen(cl));
-- strcpy(endstr, cl);
-- }
-- ds = tgoto(tgetstr("cs", &pt), tgetnum("li") - 1, 0);
-- adjstr(ds);
-- if (ds) {
-- strcat(endstr, ds);
-- strcat(endstr, ce);
-- }
-- ts = tgoto(tgetstr("cm", &pt), 0, tgetnum("li") - 1);
-- adjstr(ts);
-- }
-+ gettermcap();
-
- // ウィンドウのサイズを設定し直す (stty -a の 行数/桁数 等)
- struct winsize win;
---- a/pty.H
-+++ b/pty.H
-@@ -50,18 +50,21 @@
- int rfd;
- static int wfd;
- private:
-- static void adjstr(char* str);
-+ static char buf[BUFSIZ];
-+ static char funcstr[BUFSIZ];
-+private:
-+ static void gettermcap();
- protected:
- static int hs;
-- char* so;
-- char* se;
-- char* us;
-- char* ue;
-- char* sc;
-- char* rc;
-+ static char* so;
-+ static char* se;
-+ static char* us;
-+ static char* ue;
-+ static char* sc;
-+ static char* rc;
- static char* ce;
- static char* ts;
-- char* fs;
-+ static char* fs;
- static char* ds;
- private:
- static void finish();
diff --git a/app-i18n/canfep/metadata.xml b/app-i18n/canfep/metadata.xml
deleted file mode 100644
index e1a49f498885..000000000000
--- a/app-i18n/canfep/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>cjk@gentoo.org</email>
- <name>Cjk</name>
- </maintainer>
-</pkgmetadata>