summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/fcitx-chewing/fcitx-chewing-5.1.1.ebuild')
-rw-r--r--app-i18n/fcitx-chewing/fcitx-chewing-5.1.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-i18n/fcitx-chewing/fcitx-chewing-5.1.1.ebuild b/app-i18n/fcitx-chewing/fcitx-chewing-5.1.1.ebuild
new file mode 100644
index 000000000000..7a2ba6c6a106
--- /dev/null
+++ b/app-i18n/fcitx-chewing/fcitx-chewing-5.1.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="fcitx5-chewing"
+
+inherit cmake xdg
+
+DESCRIPTION="Chewing Wrapper for Fcitx."
+HOMEPAGE="https://github.com/fcitx/fcitx5-chewing"
+SRC_URI="https://download.fcitx-im.org/fcitx5/${MY_PN}/${MY_PN}-${PV}.tar.xz -> ${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+
+RDEPEND="
+ !app-i18n/fcitx-chewing:4
+ >=app-i18n/fcitx-5.1.6:5
+ >=app-i18n/libchewing-0.5.0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_PN}-${PV}"