summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/fcitx-lua')
-rw-r--r--app-i18n/fcitx-lua/Manifest1
-rw-r--r--app-i18n/fcitx-lua/fcitx-lua-5.0.13.ebuild45
-rw-r--r--app-i18n/fcitx-lua/metadata.xml31
3 files changed, 77 insertions, 0 deletions
diff --git a/app-i18n/fcitx-lua/Manifest b/app-i18n/fcitx-lua/Manifest
new file mode 100644
index 000000000000..f8c660804087
--- /dev/null
+++ b/app-i18n/fcitx-lua/Manifest
@@ -0,0 +1 @@
+DIST fcitx-lua-5.0.13.tar.zst 40578 BLAKE2B 05defed55711d26c2fabf41e5474f7f90224a11cd8a758b5f7afc4ed6096560ab6c220745968bb0ca28367004cdf665856d04c3b52830092e3633188cd41c394 SHA512 40855f65537c2e56e1a00d7ea160d6aae9d360ff27def7f95b2f08de16c656db7a178a676f49d817b9d16eac80f73ad12f84b966eeed4a3f38f119519d288805
diff --git a/app-i18n/fcitx-lua/fcitx-lua-5.0.13.ebuild b/app-i18n/fcitx-lua/fcitx-lua-5.0.13.ebuild
new file mode 100644
index 000000000000..7a101a7c365d
--- /dev/null
+++ b/app-i18n/fcitx-lua/fcitx-lua-5.0.13.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{3,4} )
+
+MY_PN="fcitx5-lua"
+
+inherit cmake lua-single xdg unpacker
+
+DESCRIPTION="Lua support for fcitx"
+HOMEPAGE="https://github.com/fcitx/fcitx5-lua"
+SRC_URI="https://download.fcitx-im.org/fcitx5/${MY_PN}/${MY_PN}-${PV}.tar.zst -> ${P}.tar.zst"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+LICENSE="LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+IUSE="+dlopen test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${LUA_DEPS}
+ app-i18n/fcitx:5
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ kde-frameworks/extra-cmake-modules:0
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ lua-single_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_DLOPEN=$(usex dlopen)
+ -DENABLE_TEST=$(usex test)
+ )
+ cmake_src_configure
+}
diff --git a/app-i18n/fcitx-lua/metadata.xml b/app-i18n/fcitx-lua/metadata.xml
new file mode 100644
index 000000000000..152073f668d9
--- /dev/null
+++ b/app-i18n/fcitx-lua/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>tanekliang@gmail.com</email>
+ <name>Yongxiang Liang</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">fcitx/fcitx5-lua</remote-id>
+ </upstream>
+ <longdescription lang="en">
+ Lua support for fcitx.
+ It tries to support lua in fcitx in two ways.
+ 1. An addon loader for lua, which supports Type=Lua addon.
+ 2. The googlepinyin api, which is provided by imeapi addon.
+ You may put your lua file under
+ $HOME/.local/share/fcitx5/lua/imeapi/extensions
+ to make the addon find your scripts.
+ </longdescription>
+ <use>
+ <flag name="dlopen">Use dlopen to load lua library</flag>
+ </use>
+</pkgmetadata>