summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/fcitx-qt5/fcitx-qt5-1.2.0.ebuild')
-rw-r--r--app-i18n/fcitx-qt5/fcitx-qt5-1.2.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-i18n/fcitx-qt5/fcitx-qt5-1.2.0.ebuild b/app-i18n/fcitx-qt5/fcitx-qt5-1.2.0.ebuild
new file mode 100644
index 000000000000..39a4fc5f78f1
--- /dev/null
+++ b/app-i18n/fcitx-qt5/fcitx-qt5-1.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/fcitx-qt5"
+fi
+
+DESCRIPTION="Fcitx input method module for Qt 5"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx-qt5"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="BSD GPL-2+ GPL-3+ LGPL-2+"
+SLOT="4"
+KEYWORDS="~amd64 ~hppa ~ppc64 ~x86"
+IUSE=""
+
+# Private headers of dev-qt/qtgui:5 used.
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5=
+ dev-qt/qtwidgets:5
+ virtual/libintl
+ x11-libs/libxkbcommon"
+DEPEND="${RDEPEND}
+ dev-qt/qtconcurrent:5
+ kde-frameworks/extra-cmake-modules:5
+ virtual/pkgconfig"
+
+DOCS=()