summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/libhangul/libhangul-0.0.12.ebuild')
-rw-r--r--app-i18n/libhangul/libhangul-0.0.12.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-i18n/libhangul/libhangul-0.0.12.ebuild b/app-i18n/libhangul/libhangul-0.0.12.ebuild
new file mode 100644
index 000000000000..00facf07994d
--- /dev/null
+++ b/app-i18n/libhangul/libhangul-0.0.12.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+DESCRIPTION="libhangul is a generalized and portable library for processing hangul"
+HOMEPAGE="http://kldp.net/projects/hangul/"
+SRC_URI="http://kldp.net/frs/download.php/5855/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 x86"
+IUSE="nls static-libs test"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+ test? ( dev-libs/check )"
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable static-libs static) || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README || die
+}