summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/libhangul/libhangul-0.1.0.ebuild')
-rw-r--r--app-i18n/libhangul/libhangul-0.1.0.ebuild19
1 files changed, 13 insertions, 6 deletions
diff --git a/app-i18n/libhangul/libhangul-0.1.0.ebuild b/app-i18n/libhangul/libhangul-0.1.0.ebuild
index cb63ebcdd7fd..8f6b101fa56f 100644
--- a/app-i18n/libhangul/libhangul-0.1.0.ebuild
+++ b/app-i18n/libhangul/libhangul-0.1.0.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 2006-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
+
+inherit libtool
DESCRIPTION="Library for hangul input method logic, hanja dictionary"
HOMEPAGE="https://github.com/libhangul/libhangul"
@@ -9,17 +11,22 @@ SRC_URI="https://storage.googleapis.com/google-code-archive-downloads/v2/code.go
LICENSE="LGPL-2.1+"
SLOT="0/1"
-KEYWORDS="amd64 ppc ppc64 x86"
+KEYWORDS="amd64 ~arm64 ~loong ppc ppc64 ~riscv x86"
IUSE="nls static-libs test"
RESTRICT="!test? ( test )"
+BDEPEND="virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
RDEPEND="virtual/libiconv
nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
- virtual/pkgconfig
- nls? ( sys-devel/gettext )
test? ( dev-libs/check )"
+src_prepare() {
+ default
+ elibtoolize
+}
+
src_configure() {
econf \
$(use_enable nls) \
@@ -32,5 +39,5 @@ src_test() {
src_install() {
default
- find "${ED}" -name '*.la' -delete || die
+ find "${ED}" -name "*.la" -delete || die
}