summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/libkkc/libkkc-0.3.5.ebuild')
-rw-r--r--app-i18n/libkkc/libkkc-0.3.5.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-i18n/libkkc/libkkc-0.3.5.ebuild b/app-i18n/libkkc/libkkc-0.3.5.ebuild
new file mode 100644
index 000000000000..62e8f38e5140
--- /dev/null
+++ b/app-i18n/libkkc/libkkc-0.3.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ltprune python-any-r1 vala
+
+DESCRIPTION="Japanese Kana Kanji conversion input method library"
+HOMEPAGE="https://github.com/ueno/libkkc"
+SRC_URI="https://github.com/ueno/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection nls static-libs"
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/json-glib
+ dev-libs/libgee:0.8
+ dev-libs/marisa[python(+)]
+ introspection? ( dev-libs/gobject-introspection )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ $(vala_depend)
+ dev-util/intltool
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ vala_src_prepare
+ default
+}
+
+src_configure() {
+ econf \
+ $(use_enable introspection) \
+ $(use_enable nls) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}