summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/nkf')
-rw-r--r--app-i18n/nkf/nkf-2.1.4.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/app-i18n/nkf/nkf-2.1.4.ebuild b/app-i18n/nkf/nkf-2.1.4.ebuild
index 25f4cbcc3d49..6f616167fa75 100644
--- a/app-i18n/nkf/nkf-2.1.4.ebuild
+++ b/app-i18n/nkf/nkf-2.1.4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
PYTHON_COMPAT=( python3_6 )
inherit distutils-r1 perl-module toolchain-funcs vcs-snapshot
@@ -19,6 +19,10 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-macos"
IUSE="perl python l10n_ja"
+src_unpack() {
+ use python && vcs-snapshot_src_unpack || default
+}
+
src_prepare() {
sed -i \
-e "/^CFLAGS/{ s/-g -O2//; s/=/+=/; }" \