summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/tomoe-gtk/tomoe-gtk-0.6.0-r7.ebuild')
-rw-r--r--app-i18n/tomoe-gtk/tomoe-gtk-0.6.0-r7.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-i18n/tomoe-gtk/tomoe-gtk-0.6.0-r7.ebuild b/app-i18n/tomoe-gtk/tomoe-gtk-0.6.0-r7.ebuild
new file mode 100644
index 000000000000..b9861cc5dacb
--- /dev/null
+++ b/app-i18n/tomoe-gtk/tomoe-gtk-0.6.0-r7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools
+
+DESCRIPTION="Tomoe GTK+ interface widget library"
+HOMEPAGE="http://tomoe.osdn.jp/"
+SRC_URI="https://downloads.sourceforge.net/tomoe/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="app-i18n/tomoe
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-util/glib-utils
+ dev-build/gtk-doc-am
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-math.patch )
+
+AT_M4DIR="macros"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ --without-python \
+ --without-gucharmap
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+}