summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/uim')
-rw-r--r--app-i18n/uim/Manifest2
-rw-r--r--app-i18n/uim/files/uim-1.8.8-zh-TW.patch11
-rw-r--r--app-i18n/uim/files/uim-clang-16.patch44
-rw-r--r--app-i18n/uim/uim-1.8.9-r1.ebuild (renamed from app-i18n/uim/uim-1.8.9.ebuild)14
-rw-r--r--app-i18n/uim/uim-1.8.9_pre20210103-r1.ebuild249
5 files changed, 54 insertions, 266 deletions
diff --git a/app-i18n/uim/Manifest b/app-i18n/uim/Manifest
index 372e31815111..19043db7b68a 100644
--- a/app-i18n/uim/Manifest
+++ b/app-i18n/uim/Manifest
@@ -1,3 +1 @@
-DIST sigscheme-0.9.1.tar.bz2 1140162 BLAKE2B a649ec1a5ff0899af14fa686ea7cf43140c226b1df68d4c9415c3b95c7f7ae32c539df820f0e9da7d7a809c88fa388e563549728c345017dfd62d418748be7e1 SHA512 b66b901e8a6bc6d9188112f78d3ba21a2a0776e1236aa9d2d83df27cf8111b8491f665062b493d14c2a9a1b4eb47ce2789b3ca7180225a085e94623329281e09
DIST uim-1.8.9.tar.bz2 6233465 BLAKE2B 5fc57ffd43557cc685ca766d13e871a7b3ad3829fe3b3fcaa3ab76cba15350e82747952bcc77eda0093df0681ad5d3580cb30c96e2a707f0f3e2687a5bf96e19 SHA512 342bda32f27b9875bf1458adbfb3d3cdd92d98daf8068647e3cb01f9757fda6befbb44a7b9ba2b25b03e14b1de68c7e2d6b57362e84d6aae8bcff3959aaa12df
-DIST uim-1.8.9_pre20210103.tar.gz 4054622 BLAKE2B b50bafe9b0edbac1ab7e56afd5b654bdef793b606df3550ba7b8be467076005925bf2c5d221bbf3b3dbcdc5079bbb0e014ed29bef9b6a55c23384cb281411104 SHA512 39e046a8ee3bbc06ff0bab685e0ded8f63e9c474661ffecf7ed12e25cad3151498b2fecc7f14ca6f0c78974e55265df47d656a55bf158b41fe21a69071d02fe8
diff --git a/app-i18n/uim/files/uim-1.8.8-zh-TW.patch b/app-i18n/uim/files/uim-1.8.8-zh-TW.patch
deleted file mode 100644
index f73850013178..000000000000
--- a/app-i18n/uim/files/uim-1.8.8-zh-TW.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/xim/convdisp.cpp
-+++ b/xim/convdisp.cpp
-@@ -69,7 +69,7 @@
- #endif
-
- const char *fontset_zhCN = "-sony-fixed-medium-r-normal--16-*-*-*-c-80-iso8859-1, -isas-fangsong ti-medium-r-normal--16-160-72-72-c-160-gb2312.1980-0";
--const char *fontset_zhTW = "-sony-fixed-medium-r-normal--16-*-*-*-c-80-iso8859-1, -taipei-fixed-medium-r-normal--16-150-75-75-c-160-big5-0";
-+const char *fontset_zhTW = "-sony-fixed-medium-r-normal--16-*-*-*-c-80-iso8859-1, -eten-fixed-medium-r-normal--16-150-75-75-c-160-big5.eten-0";
- const char *fontset_ja = "-sony-fixed-medium-r-normal--16-*-*-*-c-80-iso8859-1, -jis-fixed-medium-r-normal--16-*-75-75-c-160-jisx0208.1983-0, -sony-fixed-medium-r-normal--16-*-*-*-c-80-jisx0201.1976-0";
- const char *fontset_ko = "-sony-fixed-medium-r-normal--16-*-*-*-c-80-iso8859-1, -daewoo-gothic-medium-r-normal--16-120-100-100-c-160-ksc5601.1987-0";
-
diff --git a/app-i18n/uim/files/uim-clang-16.patch b/app-i18n/uim/files/uim-clang-16.patch
new file mode 100644
index 000000000000..b8b32532881a
--- /dev/null
+++ b/app-i18n/uim/files/uim-clang-16.patch
@@ -0,0 +1,44 @@
+Part of this went upstream as https://github.com/uim/uim/commit/99fd890fa601b81ff99e5e0f1977fe309f56b90e.
+
+The rest was done in https://github.com/uim/uim/pull/198.
+--- a/configure.ac
++++ b/configure.ac
+@@ -601,6 +601,7 @@ if test "x$ac_cv_func_snprintf" = xyes; then
+ AC_RUN_IFELSE(
+ [AC_LANG_SOURCE([[
+ #include <stdio.h>
++#include <stdlib.h>
+ int main(void){char b[5];snprintf(b,5,"123456789");exit(b[4]!='\0');}
+ ]])],
+ [AC_MSG_RESULT(yes)],
+--- a/m4/openssl.m4
++++ b/m4/openssl.m4
+@@ -76,6 +76,7 @@ AC_MSG_CHECKING([OpenSSL header version])
+ AC_RUN_IFELSE(
+ [AC_LANG_SOURCE([[
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <string.h>
+ #include <openssl/opensslv.h>
+ #define DATA "conftest.sslincver"
+@@ -156,7 +157,9 @@ AC_ARG_WITH(openssl-header-check,
+ AC_MSG_CHECKING([whether OpenSSL's headers match the library])
+ AC_RUN_IFELSE(
+ [AC_LANG_SOURCE([[
++#include <stdlib.h>
+ #include <string.h>
++#include <openssl/crypto.h>
+ #include <openssl/opensslv.h>
+ int main(void) { exit(SSLeay() == OPENSSL_VERSION_NUMBER ? 0 : 1); }
+ ]])],
+@@ -220,8 +223,8 @@ int main(void) { DTLSv1_method(); }
+ AC_MSG_CHECKING([if programs using OpenSSL functions will link])
+ AC_LINK_IFELSE(
+ [AC_LANG_SOURCE([[
+-#include <openssl/evp.h>
+-int main(void) { SSLeay_add_all_algorithms(); }
++#include <openssl/crypto.h>
++int main(void) { OpenSSL_version_num(); }
+ ]])],
+ [
+ AC_MSG_RESULT(yes)
diff --git a/app-i18n/uim/uim-1.8.9.ebuild b/app-i18n/uim/uim-1.8.9-r1.ebuild
index 8d3071273f39..ff48ee2259e3 100644
--- a/app-i18n/uim/uim-1.8.9.ebuild
+++ b/app-i18n/uim/uim-1.8.9-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
@@ -13,7 +13,7 @@ SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.bz2"
LICENSE="BSD GPL-2 LGPL-2.1"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~riscv ~x86"
+KEYWORDS="amd64 ~arm ~hppa ppc ppc64 ~riscv x86"
IUSE="X +anthy curl eb emacs expat libffi gtk gtk2 kde l10n_ja l10n_ko l10n_zh-CN l10n_zh-TW libedit libnotify m17n-lib ncurses nls qt5 skk sqlite ssl static-libs xft"
RESTRICT="test"
REQUIRED_USE="gtk? ( X )
@@ -37,7 +37,7 @@ CDEPEND="X? (
expat? ( dev-libs/expat )
gtk? ( x11-libs/gtk+:3 )
gtk2? ( x11-libs/gtk+:2 )
- kde? ( kde-frameworks/plasma:5 )
+ kde? ( kde-plasma/libplasma:5 )
libedit? ( dev-libs/libedit )
libffi? ( dev-libs/libffi:= )
libnotify? ( x11-libs/libnotify )
@@ -80,10 +80,11 @@ RDEPEND="${CDEPEND}
BDEPEND="gnome-base/librsvg
sys-devel/gettext
virtual/pkgconfig
- kde? ( dev-util/cmake )
+ kde? ( dev-build/cmake )
nls? ( dev-util/intltool )"
PATCHES=(
+ "${FILESDIR}"/${PN}-clang-16.patch
"${FILESDIR}"/${PN}-gentoo.patch
"${FILESDIR}"/${PN}-kde.patch
"${FILESDIR}"/${PN}-slibtool.patch
@@ -92,6 +93,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-xkb.patch
"${FILESDIR}"/${PN}-zh-TW.patch
)
+
DOCS=( AUTHORS NEWS README RELNOTE doc )
SITEFILE="50${PN}-gentoo.el"
@@ -103,6 +105,10 @@ src_prepare() {
# fix build with "-march=pentium4 -O2", bug #661806
use x86 && append-cflags $(test-flags-CC -fno-inline-small-functions)
+ # Fix build w/ Clang 16+ and >= openssl 1.1.x, tries to use
+ # SSLv2_method otherwise.
+ append-cppflags -DOPENSSL_NO_SSL2
+
eautoreconf
}
diff --git a/app-i18n/uim/uim-1.8.9_pre20210103-r1.ebuild b/app-i18n/uim/uim-1.8.9_pre20210103-r1.ebuild
deleted file mode 100644
index df9c907e1f24..000000000000
--- a/app-i18n/uim/uim-1.8.9_pre20210103-r1.ebuild
+++ /dev/null
@@ -1,249 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit autotools elisp-common flag-o-matic gnome2-utils qmake-utils vcs-snapshot
-
-EGIT_COMMIT="d1ac9d9315ff8c57c713b502544fef9b3a83b3e5"
-SIG_PV="0.9.1"
-
-DESCRIPTION="A multilingual input method framework"
-HOMEPAGE="https://github.com/uim/uim"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz
- https://github.com/${PN}/sigscheme/releases/download/${SIG_PV}/sigscheme-${SIG_PV}.tar.bz2"
-
-LICENSE="BSD GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~hppa ppc ppc64 ~riscv x86"
-IUSE="X +anthy curl eb emacs expat libffi gtk gtk2 kde l10n_ja l10n_ko l10n_zh-CN l10n_zh-TW libedit libnotify m17n-lib ncurses nls qt5 skk sqlite ssl static-libs xft"
-RESTRICT="test"
-REQUIRED_USE="gtk? ( X )
- gtk2? ( X )
- qt5? ( X )
- xft? ( X )"
-
-CDEPEND="X? (
- x11-libs/libICE
- x11-libs/libSM
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXft
- x11-libs/libXrender
- x11-libs/libXt
- )
- anthy? ( app-i18n/anthy )
- curl? ( net-misc/curl )
- eb? ( dev-libs/eb )
- emacs? ( >=app-editors/emacs-23.1:* )
- expat? ( dev-libs/expat )
- gtk? ( x11-libs/gtk+:3 )
- gtk2? ( x11-libs/gtk+:2 )
- kde? ( kde-frameworks/plasma:5 )
- libedit? ( dev-libs/libedit )
- libffi? ( dev-libs/libffi:= )
- libnotify? ( x11-libs/libnotify )
- m17n-lib? ( dev-libs/m17n-lib )
- ncurses? ( sys-libs/ncurses:0= )
- nls? ( virtual/libintl )
- qt5? (
- dev-qt/qtx11extras:5
- dev-qt/qtwidgets:5
- )
- skk? ( app-i18n/skk-jisyo )
- sqlite? ( dev-db/sqlite:3 )
- ssl? ( dev-libs/openssl:0= )"
-DEPEND="${CDEPEND}
- X? ( x11-base/xorg-proto )"
-RDEPEND="${CDEPEND}
- !dev-scheme/sigscheme
- X? (
- media-fonts/font-sony-misc
- l10n_ja? (
- || (
- media-fonts/font-jis-misc
- media-fonts/intlfonts
- )
- )
- l10n_ko? (
- || (
- media-fonts/font-daewoo-misc
- media-fonts/intlfonts
- )
- )
- l10n_zh-CN? (
- || (
- media-fonts/font-isas-misc
- media-fonts/intlfonts
- )
- )
- l10n_zh-TW? ( media-fonts/intlfonts )
- )"
-BDEPEND="dev-util/intltool
- gnome-base/librsvg
- sys-devel/gettext
- virtual/pkgconfig
- kde? ( dev-util/cmake )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-gentoo.patch
- "${FILESDIR}"/${PN}-kde.patch
- "${FILESDIR}"/${PN}-slibtool.patch
- "${FILESDIR}"/${PN}-tinfo.patch
- "${FILESDIR}"/${PN}-Wconversion.patch
- "${FILESDIR}"/${PN}-xkb.patch
- "${FILESDIR}"/${PN}-1.8.8-zh-TW.patch
-)
-DOCS=( AUTHORS NEWS README RELNOTE doc )
-
-SITEFILE="50${PN}-gentoo.el"
-
-src_unpack() {
- vcs-snapshot_src_unpack
- rmdir "${S}"/sigscheme || die
- mv "${WORKDIR}"/sigscheme-${SIG_PV} "${S}"/sigscheme || die
-}
-
-src_prepare() {
- default
- sed -i "s:\$libedit_path/lib:/$(get_libdir):g" configure.ac
- # fix build with >=dev-scheme/chicken-4, bug #656852
- touch scm/json-parser-expanded.scm
- # fix build with "-march=pentium4 -O2", bug #661806
- use x86 && append-cflags $(test-flags-CC -fno-inline-small-functions)
-
- eautoreconf
-}
-
-src_configure() {
- local myconf=(
- $(use_with X x)
- $(use_with anthy anthy-utf8)
- $(use_with curl)
- $(use_with eb)
- $(use_enable emacs)
- $(use_with emacs lispdir "${SITELISP}")
- $(use_with expat)
- $(use_enable kde kde5-applet)
- $(use_with libedit)
- $(use_with libffi ffi)
- $(use_with gtk gtk3)
- $(use_with gtk2)
- $(use_with m17n-lib m17nlib)
- $(use_enable ncurses fep)
- $(use_enable nls)
- $(use_with qt5)
- $(use_with qt5 qt5-immodule)
- _QMAKE5=$(qt5_get_bindir)/qmake
- $(use_with skk)
- $(use_with sqlite sqlite3)
- $(use_enable ssl openssl)
- $(use_enable static-libs static)
- $(use_with xft)
- --without-anthy
- --without-canna
- --enable-default-toolkit=$(usex gtk gtk3 $(usex gtk2 gtk $(usex qt5 qt5)))
- --disable-gnome-applet
- --disable-gnome3-applet
- --disable-kde-applet
- --disable-kde4-applet
- --without-mana
- --enable-maintainer-mode
- --without-prime
- --disable-qt4-qt3support
- )
-
- if (use gtk || use gtk2) && use anthy; then
- myconf+=( --enable-dict )
- else
- myconf+=( --disable-dict )
- fi
-
- if use libnotify; then
- myconf+=( --enable-notify=libnotify )
- fi
-
- if use gtk || use gtk2 || use qt5; then
- myconf+=( --enable-pref )
- else
- myconf+=( --disable-pref )
- fi
-
- econf "${myconf[@]}"
-}
-
-src_compile() {
- default
-
- if use emacs; then
- cd emacs || die
- elisp-compile *.el || die
- cd - >/dev/null || die
- fi
-}
-
-src_install() {
- # bug #222677
- emake -j1 DESTDIR="${D}" install
- rm -f doc/Makefile*
- einstalldocs
-
- find "${ED}"/usr/$(get_libdir)/${PN} -name '*.la' -delete || die
- use static-libs || find "${ED}" -name '*.la' -delete || die
-
- insinto /etc/X11/xinit/xinput.d
- sed \
- -e "s:@EPREFIX@:${EPREFIX}:g" \
- "${FILESDIR}"/xinput-${PN} > "${T}"/${PN}.conf
- doins "${T}"/${PN}.conf
-
- if use X; then
- docinto xim
- dodoc xim/README*
- fi
-
- if use emacs; then
- elisp-install ${PN}-el emacs/*.el{,c}
- elisp-site-file-install "${FILESDIR}"/${SITEFILE} ${PN}-el
- docinto emacs
- dodoc emacs/README*
- fi
-
- if use ncurses; then
- docinto fep
- dodoc fep/README*
- fi
-}
-
-pkg_postinst() {
- elog "New input method switcher has been introduced. You need to set"
- elog
- elog "% GTK_IM_MODULE=uim ; export GTK_IM_MODULE"
- elog "% QT_IM_MODULE=uim ; export QT_IM_MODULE"
- elog "% XMODIFIERS=@im=uim ; export XMODIFIERS"
- elog
- elog "If you would like to use uim-anthy as default input method, put"
- elog "(define default-im-name 'anthy)"
- elog "to your ~/.uim."
- elog
- elog "All input methods can be found by running uim-im-switcher-gtk, "
- elog "uim-im-switcher-gtk3 or uim-im-switcher-qt5."
-
- if use emacs; then
- elisp-site-regen
- elog
- elog "uim is autoloaded with Emacs with a minimal set of features:"
- elog "There is no keybinding defined to call it directly, so please"
- elog "create one yourself and choose an input method."
- elog "Integration with LEIM is not done with this ebuild, please have"
- elog "a look at the documentation how to achieve this."
- fi
- use gtk && gnome2_query_immodules_gtk3
- use gtk2 && gnome2_query_immodules_gtk2
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
- use gtk && gnome2_query_immodules_gtk3
- use gtk2 && gnome2_query_immodules_gtk2
-}