summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/unicode-emoji/unicode-emoji-11.0.ebuild')
-rw-r--r--app-i18n/unicode-emoji/unicode-emoji-11.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-i18n/unicode-emoji/unicode-emoji-11.0.ebuild b/app-i18n/unicode-emoji/unicode-emoji-11.0.ebuild
new file mode 100644
index 000000000000..8a9a211570ba
--- /dev/null
+++ b/app-i18n/unicode-emoji/unicode-emoji-11.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+DESCRIPTION="UTS #51 Unicode Emoji"
+HOMEPAGE="https://unicode.org/emoji/"
+BASE_URI="https://unicode.org/Public/${PN#*-}/${PV}"
+SRC_URI="${BASE_URI}/${PN#*-}-data.txt -> ${PN}-data-${PV}.txt
+ ${BASE_URI}/${PN#*-}-sequences.txt -> ${PN}-sequences-${PV}.txt
+ ${BASE_URI}/${PN#*-}-test.txt -> ${PN}-test-${PV}.txt
+ ${BASE_URI}/${PN#*-}-variation-sequences.txt -> ${PN}-variation-sequences-${PV}.txt
+ ${BASE_URI}/${PN#*-}-zwj-sequences.txt -> ${PN}-zwj-sequences-${PV}.txt"
+
+LICENSE="unicode"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}"
+
+src_unpack() {
+ :
+}
+
+src_install() {
+ insinto /usr/share/unicode/emoji
+ local file
+ for file in ${A}; do
+ newins "${DISTDIR}/${file}" "$(sed -e "s/${PN%-*}-\(.*\)-${PV}/\1/" <<< "${file}")"
+ done
+}