summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/librime/files/librime-1.6.0-boost-1.76.patch24
-rw-r--r--app-i18n/librime/librime-1.6.0.ebuild3
-rw-r--r--app-i18n/librime/librime-1.6.1.ebuild3
-rw-r--r--app-i18n/librime/librime-1.7.3.ebuild2
4 files changed, 30 insertions, 2 deletions
diff --git a/app-i18n/librime/files/librime-1.6.0-boost-1.76.patch b/app-i18n/librime/files/librime-1.6.0-boost-1.76.patch
new file mode 100644
index 000000000000..5ed1447359d6
--- /dev/null
+++ b/app-i18n/librime/files/librime-1.6.0-boost-1.76.patch
@@ -0,0 +1,24 @@
+https://github.com/rime/librime/issues/462
+https://github.com/rime/librime/pull/463
+https://github.com/rime/librime/commit/57cffcd02ac70148e21ce982be834876b3df87db
+
+--- /src/rime/gear/script_translator.cc
++++ /src/rime/gear/script_translator.cc
+@@ -8,6 +8,7 @@
+ //
+ #include <algorithm>
+ #include <stack>
++#include <cmath>
+ #include <boost/algorithm/string/join.hpp>
+ #include <boost/range/adaptor/reversed.hpp>
+ #include <rime/composition.h>
+--- /src/rime/gear/table_translator.cc
++++ /src/rime/gear/table_translator.cc
+@@ -6,6 +6,7 @@
+ //
+ #include <boost/algorithm/string.hpp>
+ #include <boost/range/adaptor/reversed.hpp>
++#include <cmath>
+ #include <utf8.h>
+ #include <rime/candidate.h>
+ #include <rime/common.h>
diff --git a/app-i18n/librime/librime-1.6.0.ebuild b/app-i18n/librime/librime-1.6.0.ebuild
index eef1faa5bd5f..c3c438bc80de 100644
--- a/app-i18n/librime/librime-1.6.0.ebuild
+++ b/app-i18n/librime/librime-1.6.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2012-2020 Gentoo Authors
+# Copyright 2012-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -43,6 +43,7 @@ DEPEND="${RDEPEND}
DOCS=(CHANGELOG.md README.md)
src_prepare() {
+ eapply "${FILESDIR}/${PN}-1.6.0-boost-1.76.patch"
eapply "${FILESDIR}/${PN}-1.6.0-plugins.patch"
# Use headers of dev-libs/darts, dev-libs/utfcpp and x11-base/xorg-proto.
diff --git a/app-i18n/librime/librime-1.6.1.ebuild b/app-i18n/librime/librime-1.6.1.ebuild
index 91cdfdf161d4..e1a0804e63a9 100644
--- a/app-i18n/librime/librime-1.6.1.ebuild
+++ b/app-i18n/librime/librime-1.6.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2012-2020 Gentoo Authors
+# Copyright 2012-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -43,6 +43,7 @@ DEPEND="${RDEPEND}
DOCS=(CHANGELOG.md README.md)
src_prepare() {
+ eapply "${FILESDIR}/${PN}-1.6.0-boost-1.76.patch"
eapply "${FILESDIR}/${PN}-1.6.1-plugins.patch"
# Use headers of dev-libs/darts, dev-libs/utfcpp and x11-base/xorg-proto.
diff --git a/app-i18n/librime/librime-1.7.3.ebuild b/app-i18n/librime/librime-1.7.3.ebuild
index 03e55e308b4c..44310ba275b7 100644
--- a/app-i18n/librime/librime-1.7.3.ebuild
+++ b/app-i18n/librime/librime-1.7.3.ebuild
@@ -43,6 +43,8 @@ DEPEND="${RDEPEND}
DOCS=(CHANGELOG.md README.md)
src_prepare() {
+ eapply "${FILESDIR}/${PN}-1.6.0-boost-1.76.patch"
+
# Use headers of dev-libs/darts, dev-libs/utfcpp and x11-base/xorg-proto.
sed -e "/\${PROJECT_SOURCE_DIR}\/thirdparty/d" -i CMakeLists.txt || die
rm -r thirdparty || die