summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/fbterm/fbterm-1.7_p20190503.ebuild10
-rw-r--r--app-i18n/fbterm/files/fbterm-autoconf-2.68.patch24
2 files changed, 30 insertions, 4 deletions
diff --git a/app-i18n/fbterm/fbterm-1.7_p20190503.ebuild b/app-i18n/fbterm/fbterm-1.7_p20190503.ebuild
index c6271dc437cd..408aa38f9e12 100644
--- a/app-i18n/fbterm/fbterm-1.7_p20190503.ebuild
+++ b/app-i18n/fbterm/fbterm-1.7_p20190503.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -16,13 +16,15 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="gpm video_cards_vesa"
-BDEPEND="virtual/pkgconfig"
-DEPEND="media-libs/fontconfig
+RDEPEND="media-libs/fontconfig
media-libs/freetype:2
>=sys-libs/ncurses-6.1
gpm? ( sys-libs/gpm )
video_cards_vesa? ( dev-libs/libx86 )"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-autoconf-2.68.patch )
FILECAPS=(
cap_sys_tty_config+ep usr/bin/${PN}
diff --git a/app-i18n/fbterm/files/fbterm-autoconf-2.68.patch b/app-i18n/fbterm/files/fbterm-autoconf-2.68.patch
new file mode 100644
index 000000000000..826f3cd3c6bc
--- /dev/null
+++ b/app-i18n/fbterm/files/fbterm-autoconf-2.68.patch
@@ -0,0 +1,24 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -85,16 +85,16 @@
+
+ if test x"$EPOLL" = xauto -a x"$cross_compiling" = xno; then
+ AC_RUN_IFELSE(
+- AC_LANG_PROGRAM([[#include <sys/epoll.h>]],
+- [[if (epoll_create(10) >= 0) return 0; return 1;]]),
++ [AC_LANG_PROGRAM([[#include <sys/epoll.h>]],
++ [[if (epoll_create(10) >= 0) return 0; return 1;]])],
+ [EPOLL=yes]
+ )
+ fi
+
+ if test x"$SIGNALFD" = xauto -a x"$cross_compiling" = xno; then
+ AC_RUN_IFELSE(
+- AC_LANG_PROGRAM([[#include <sys/signalfd.h>]],
+- [[sigset_t mask; if (signalfd(-1, &mask, 0) >= 0) return 0; return 1;]]),
++ [AC_LANG_PROGRAM([[#include <sys/signalfd.h>]],
++ [[sigset_t mask; if (signalfd(-1, &mask, 0) >= 0) return 0; return 1;]])],
+ [SIGNALFD=yes]
+ )
+ fi
+install-data-local: