summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-laptop/framework-laptop-kmod/framework-laptop-kmod-0_pre20231129.ebuild')
-rw-r--r--app-laptop/framework-laptop-kmod/framework-laptop-kmod-0_pre20231129.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-laptop/framework-laptop-kmod/framework-laptop-kmod-0_pre20231129.ebuild b/app-laptop/framework-laptop-kmod/framework-laptop-kmod-0_pre20231129.ebuild
new file mode 100644
index 000000000000..ae4a4b4c5960
--- /dev/null
+++ b/app-laptop/framework-laptop-kmod/framework-laptop-kmod-0_pre20231129.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-mod-r1
+
+COMMIT_HASH="fed64af4c19a15ef6bb7dca79b692d265e845699"
+DESCRIPTION="Kernel module to expose more Framework Laptop stuff"
+HOMEPAGE="https://github.com/DHowett/framework-laptop-kmod"
+SRC_URI="https://github.com/DHowett/framework-laptop-kmod/archive/${COMMIT_HASH}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT_HASH}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+CONFIG_CHECK="
+ ~CROS_EC
+ ~CROS_EC_LPC
+"
+
+DOCS=(
+ README.md
+)
+
+pkg_pretend() {
+ check_extra_config
+}
+
+src_compile() {
+ local modlist=(
+ framework_laptop
+ )
+ linux-mod-r1_src_compile
+}
+
+pkg_postinst() {
+ linux-mod-r1_pkg_postinst
+
+ #if kernel_is -lt 6 7 0; then
+ ewarn "For the Framework Laptop 13 AMD Ryzen 7040 series and the Framework Laptop 16a,"
+ ewarn "you will need to apply the patch series from this URL:"
+ ewarn "https://lore.kernel.org/chrome-platform/20231005160701.19987-1-dustin@howett.net/"
+ #fi
+}