summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-laptop/tpacpi-bat/tpacpi-bat-9999.ebuild')
-rw-r--r--app-laptop/tpacpi-bat/tpacpi-bat-9999.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/app-laptop/tpacpi-bat/tpacpi-bat-9999.ebuild b/app-laptop/tpacpi-bat/tpacpi-bat-9999.ebuild
index 39f5df050623..74b72ce18688 100644
--- a/app-laptop/tpacpi-bat/tpacpi-bat-9999.ebuild
+++ b/app-laptop/tpacpi-bat/tpacpi-bat-9999.ebuild
@@ -1,31 +1,32 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit systemd
-if [ "${PV}" = "9999" ]; then
+DESCRIPTION="Control battery thresholds of recent ThinkPads, not supported by tp_smapi"
+HOMEPAGE="https://github.com/teleshoes/tpacpi-bat"
+
+if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/teleshoes/tpacpi-bat.git"
else
SRC_URI="https://github.com/teleshoes/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
fi
-DESCRIPTION="Control battery thresholds of recent ThinkPads, not supported by tp_smapi"
-HOMEPAGE="https://github.com/teleshoes/tpacpi-bat"
LICENSE="GPL-3"
SLOT="0"
-IUSE=""
-DEPEND=""
-RDEPEND="sys-power/acpi_call
+RDEPEND="
+ sys-power/acpi_call
dev-lang/perl"
src_install() {
- dodoc README.md battery_asl
dobin tpacpi-bat
+ dodoc README.md battery_asl
+
newinitd "${FILESDIR}"/${PN}.initd.2 ${PN}
newconfd "${FILESDIR}"/${PN}.confd.1 ${PN}
systemd_newunit examples/systemd_fixed_threshold/tpacpi.service \