summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-laptop/tuxedo-control-center-bin')
-rw-r--r--app-laptop/tuxedo-control-center-bin/files/tccd.initd25
-rw-r--r--app-laptop/tuxedo-control-center-bin/tuxedo-control-center-bin-1.1.0-r1.ebuild (renamed from app-laptop/tuxedo-control-center-bin/tuxedo-control-center-bin-1.1.0.ebuild)2
2 files changed, 27 insertions, 0 deletions
diff --git a/app-laptop/tuxedo-control-center-bin/files/tccd.initd b/app-laptop/tuxedo-control-center-bin/files/tccd.initd
new file mode 100644
index 000000000000..ced84c8baa60
--- /dev/null
+++ b/app-laptop/tuxedo-control-center-bin/files/tccd.initd
@@ -0,0 +1,25 @@
+#!/sbin/openrc-run
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+name=$RC_SVCNAME
+description="TUXEDO Control Center Service"
+supervisor="supervise-daemon"
+command="/opt/tuxedo-control-center/resources/dist/tuxedo-control-center/data/service/tccd"
+command_args="--start"
+
+depend() {
+ need localmount
+}
+
+start(){
+ ebegin "Starting $RC_SVCNAME"
+ start-stop-daemon -b --start /opt/tuxedo-control-center/resources/dist/tuxedo-control-center/data/service/tccd -- --start
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping $RC_SVCNAME"
+ /opt/tuxedo-control-center/resources/dist/tuxedo-control-center/data/service/tccd --stop
+ eend $?
+}
diff --git a/app-laptop/tuxedo-control-center-bin/tuxedo-control-center-bin-1.1.0.ebuild b/app-laptop/tuxedo-control-center-bin/tuxedo-control-center-bin-1.1.0-r1.ebuild
index 26e89d4b651e..3cc707212c10 100644
--- a/app-laptop/tuxedo-control-center-bin/tuxedo-control-center-bin-1.1.0.ebuild
+++ b/app-laptop/tuxedo-control-center-bin/tuxedo-control-center-bin-1.1.0-r1.ebuild
@@ -47,6 +47,8 @@ src_install() {
systemd_dounit opt/tuxedo-control-center/resources/dist/tuxedo-control-center/data/dist-data/tccd.service
systemd_dounit opt/tuxedo-control-center/resources/dist/tuxedo-control-center/data/dist-data/tccd-sleep.service
+
+ doinitd "${FILES}/tccd.initd"
}
pkg_config() {