summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/tuxedo-keyboard/Manifest1
-rw-r--r--app-laptop/tuxedo-keyboard/tuxedo-keyboard-3.2.3.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/app-laptop/tuxedo-keyboard/Manifest b/app-laptop/tuxedo-keyboard/Manifest
index 91f26106d86e..a0c7396ee7a2 100644
--- a/app-laptop/tuxedo-keyboard/Manifest
+++ b/app-laptop/tuxedo-keyboard/Manifest
@@ -1,3 +1,4 @@
DIST tuxedo-keyboard-3.0.10.tar.gz 50759 BLAKE2B 08fec486f6555ff5b8de6b1ea49ce504747238284fda31b05686fd5955bf3bb3fc48b49c40b50c1bbdfcbf4af2f206a99f645b294ebceafec4c87751fd460090 SHA512 a3c5b74fc5587763f131a66f507c0b33d462ed87c8e05391152c09d1425b5e1771bfb08cc2d1e3bb73b02074f503d866ea463fd44fb06d00b38c6ac4cfcd4e3b
DIST tuxedo-keyboard-3.1.3.tar.gz 56532 BLAKE2B 06c2dec95e7888f765040bd41512c691cab9812fbea213b7766605aad6724adf3d5c6e5a3641621781f483e1ce249e71ea988b765e311d4bb4862997d8effb2c SHA512 dbad1ebc5d91d3306197012ce2fafa5e6063c9b8b62a14c3f1412c9340199c91500a6eeefbed73b1a5d15132dc4b4a73e11c86c15c1b2a3d44765b2664d2f331
DIST tuxedo-keyboard-3.2.1.tar.gz 58606 BLAKE2B 5b358eea14db5f1ac595468e53cd39f026dc92203209c933df34a7d552dc5d9160fdd1d3867a87580518285ee5558fd983fb6b8c193362cde9ea1bf5689949be SHA512 35aaf129d3a75dd38107c2e20fdc066dc1161419a452716458d556b48dacfd42538bd36729a8f468ba838f7203cceeea24c5851de5bdae9c1b21d9d98f342a87
+DIST tuxedo-keyboard-3.2.3.tar.gz 59913 BLAKE2B 113fef200d6c9f9fa0158a77dbed8c9f8d91ce14db78ae9a306ebd8a802ab5f6838f96b0d689eb6b7a4a8187ac023fec6eda2cd52ed83ba521ad5db3cb96c58a SHA512 9f62c6c603d7aa0b4870c4786526d5f7aa6e96104820ecb00eeaf941ea11ac3ceee849189f6f1e09519c201ea89aca58c19374beb90b087ed347e60fe850fad5
diff --git a/app-laptop/tuxedo-keyboard/tuxedo-keyboard-3.2.3.ebuild b/app-laptop/tuxedo-keyboard/tuxedo-keyboard-3.2.3.ebuild
new file mode 100644
index 000000000000..b3fce1cb74dc
--- /dev/null
+++ b/app-laptop/tuxedo-keyboard/tuxedo-keyboard-3.2.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+CONFIG_CHECK="ACPI_WMI INPUT_SPARSEKMAP"
+
+inherit linux-mod toolchain-funcs
+
+DESCRIPTION="Kernel Module for Tuxedo Keyboard"
+HOMEPAGE="https://github.com/tuxedocomputers/tuxedo-keyboard"
+SRC_URI="https://github.com/tuxedocomputers/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BUILD_TARGETS="all"
+MODULE_NAMES="clevo_acpi(tuxedo:${S}:src) clevo_wmi(tuxedo:${S}:src) uniwill_wmi(tuxedo:${S}:src) tuxedo_keyboard(tuxedo:${S}:src) tuxedo_io(tuxedo:${S}:src/tuxedo_io)"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.2.1-rm-unused-functions.patch )
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="CC=$(tc-getBUILD_CC) KDIR=${KV_DIR} V=1 KBUILD_VERBOSE=1"
+}