summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-leechcraft/lc-lmp/lc-lmp-0.6.65.ebuild')
-rw-r--r--app-leechcraft/lc-lmp/lc-lmp-0.6.65.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-leechcraft/lc-lmp/lc-lmp-0.6.65.ebuild b/app-leechcraft/lc-lmp/lc-lmp-0.6.65.ebuild
new file mode 100644
index 000000000000..f432d62c2c48
--- /dev/null
+++ b/app-leechcraft/lc-lmp/lc-lmp-0.6.65.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit leechcraft
+
+DESCRIPTION="LeechCraft Media Player, Phonon-based audio/video player"
+
+SLOT="0"
+KEYWORDS=" ~amd64 ~x86"
+IUSE="debug +graffiti +guess +mpris +mp3tunes"
+
+# depend on gstreamer:0.10 to match current Qt deps
+DEPEND="~app-leechcraft/lc-core-${PV}
+ graffiti? ( media-libs/flac )
+ guess? ( app-i18n/libguess )
+ media-libs/gstreamer:0.10
+ media-libs/taglib
+ mpris? ( dev-qt/qtdbus:4 )
+ dev-qt/qtdeclarative:4"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs="
+ $(cmake-utils_use_enable graffiti LMP_GRAFFITI)
+ $(cmake-utils_use_enable guess LMP_LIBGUESS)
+ $(cmake-utils_use_enable mpris LMP_MPRIS)
+ $(cmake-utils_use_enable mp3tunes LMP_MP3TUNES)"
+ cmake-utils_src_configure
+}